A-Star "SDTest.ino" problems

I’m using an A-Star 32U4 Prime LV.
I’m running the “SDTest.ino” example sketch with all the “LCD” lines removed (I don’t have a LCD)
I added these 2 lines:
Serial.begin(115200); // also tried 9600
before this line:
Serial.print(“Initializing SD card…”);
I added those lines because I never saw the “Initializing SD card…” line.

Case #1: /CS jumper installed
I get the Red, Green, and Yellow LEDs blinking but no text in serial monitor.

Case #2: /CS not jumper installed
Still no text but red LED blinks & a buzzer tone is heard.

Case #3: /CS not jumper installed, recently uploaded sketch.
Red LED blinks & a buzzer tone is heard and only text in serial monitor is “Card failed, or not present” (no “Initializing SD card…”)

I’m running on a MacBook Pro. The “System Profiler” shows a “Pololu A-Star 32U4” in the list of USB devices with this information:
Product ID: 0x2300
Vendor ID: 0x1ffb
Version: 1.00
Speed: Up to 12 Mb/sec
Manufacturer: Pololu Corporation
Location ID: 0xfa130000 / 6
Current Available (mA): 500
Current Required (mA): 500

I tried the “BuzzerBasics.ino” sketch before & after trying the “SDTest.ino” sketch. “SDTest.ino” produces the two tones and the “fugue”. Also tried “BlinkLEDs.ino”. It appears to work as expected.

I’ using the “AStar32U4” library (May 29, 2019 version).

What do you suggest I try next?


Did you create a test.txt file on your SD card and put some text in it before testing it? Could you also try another program that prints to the Serial Monitor to confirm that is working properly, like Arduino’s built in AnalogReadSerial example (which is under “01.Basics” in the Arduino IDE’s “Examples” menu)?

- Patrick