A-Star, losing USB COM port in Arduino IDE

OS: Windows7
board: A-Star Mini SV
programmer: Arduino IDE with A-Star USB programmer chosen and COM5 port.

I have installed the drivers and add-on 1.2.0 to allow programming of A-Star from Arduino IDE. When I try to upload to the board, it often fails. The USB COM port seems to disappear from the IDE port listings after a sketch is run. I have to reset the board, often several times, sometimes with a double click of the reset button for the upload to work. After upload to the board it again loses the USB COM port in the IDE. I haven’t had this problem with the IDE before with my Arduino UNO or other Arduino clones.

Is this something with either the Arduino programmer config or the board bootloader that is not allowing it to be set for program loading once you have run a sketch on the board? Can anything be done to fix it? It slows the development cycle.



I am sorry you are having problems with your A-Star. What is the last program you loaded on the A-Star? Can you post a screenshot of the Windows Device Manager with the Pololu USB Devices and the Ports (COM & LPT) tabs expanded to show the entries for them?


Something simple. I read somewhere that using the Serial object won’t work with the serial monitor in the IDE for USB connections. If that is true, is there a difference between using an FTDI interface on a board and the AVR USB 328? Is the solution just to use a USB to serial converter for a separate COM port?

[code]void setup(){

void loop() {

I am not sure what you are trying to say in your last post. You should not need to do anything special to program an A-Star. You should just connect it through USB and select the correct board and COM port; then hit upload (just like a standard Arduino).

I loaded your code into an A-Star and was able to repeatedly program both your code and other sketches without any issues. Is that the last code you programmed onto the A-Star before it started having problems? Have you tried any other code? If so, does it have the same issue? Has the A-Star behaved like this since you got it or were you able to program it reliably a number of times before it stopped working? If it was working reliably at some point, did something happen between when it worked and when it started showing this behavior (e.g. it got disconnected during programming)?

Can you try a different USB cable to see if the problem goes away? Also, can you post the screen capture of the Windows Device Manager as I asked previously?