Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

A-Star Driver Installation Problem


#1

Hello,

I am trying to get the Pololu Balboa to work, but am unable to get the A-star driver to install.
I am on Windows 7 and am logged in as an administrator.

I’ve downloaded the a-star-windows driver and extracted the contents to a folder.
I right-clicked the a-star.inf file and selected install. I expected to get a “Would you like to install this device software” window, but nothing happens.

When the Balboa is plugged in, windows Device Manager shows it as an unknown device.

I also tried to install the driver through the Device Manager and selected the correct folder containing the a-star.inf file.
But the device manager says “Windows cannot find driver software for your device” even though the a-star.inf file is in that folder.

I would appreciate any help getting this resolved.

Thank!


#2

Hello.

Could you try tapping the reset button twice within 750 ms (to put the 32U4 in bootloader mode) while looking at the device manager to see if a port shows up?

-Nathan


#3

I tried doing this and still no difference. It still shows up as an “Unknown Device” under “Other Devices”.

FYR, the LED labeled 13 on the board was blinking at a higher rate after I hid the reset button twice in rapid succession.

Thanks.


#4

How is the A-Star connected to your computer? If you are using a USB hub, can you try connecting it directly to one of the USB ports on your computer? If you have it directly connected, could you try a different USB port? Could you also try a different USB cable?

If the A-star is still not recognized after those steps, can you select the “Devices by connection” option under the “View” menu in the Device Manager, expand all of the “USB host controller” entries, and post a screenshot here?

-Nathan


#5

The Pololu Balboa is connected directly through a USB cable. I have tried using different ports, and USB cables as well.

I did not see an entry for “USB host controller” in Device Manager under “Devices by Connection”. In any case, here is the screen shot. I believe that the Balboa is the “Unknown Device” here.

Thanks.

Device Manager Screenshot

Top Level Device Manager Screen Shot


#6

Sorry for the delayed reply. We missed your post. Can you expand everything beneath the “Generic USB Hub” you show in your “Device Manager Screenshot” image? Have you tried connecting the board to any other computers?

We would not expect the Balboa to appear as an unknown device directly connected to your PCI Bus. The Balboa uses USB, not PCI, to connect to the computer. If you think a particular entry corresponds to a Balboa, you can test that by disconnecting it and seeing if the entry disappears.

-Nathan


#7

Thanks for your reply. A screenshot of the device manager with the Generic USB Hub expanded is here.

I think I was mistaken about the “Unknown Device” being the Balboa as it didn’t disappear from the Device Manager when I disconnected it.

I haven’t had a chance to test this on another Windows PC yet.

Thanks.


#8

Does the board otherwise seem to be working? Do any lights come on when you plug the board into USB? Have you tried using the USB cable to transfer data with another device? Can you post pictures that show the board including any soldered connections you made?

-Nathan


#9

Hi Nathan,

I figured out the problem. It is an issue with the USB hardware on my computer which was flaky.
I figured it out because it worked with a different computer.

Thank you so much for your assistance.