8 Ch Micro Servo Controller 18f2520

I have a similar set up with a Scott Edwards and is working fine. I am trying to set it up with a Pololu and I am having trouble getting it to respond to serial commands. I have both the Hardware Serial and the software serial to both inputs and have not had any luck. I only get the yellow light except when I tried the Hardware Serial. Then I got the red stop light.

I am powering the board and the servos through a 2 amp 5v power source. This is an example of my commands:

serout PORTC.5,N2400,[128,1,4,0,35,127]
pause 500
serout PORTC.5,N2400,[$80,$01,$04,0,13,127]
pause 500

For hardware serial:
hserout [$80,$01,$04,0,13,127]

I am not sure what else to try.


I submitted this on Friday and it was posted this morning. No that is not what is dumb. I had a lot of time to work on it this weekend and I got it figured out.

I knew I was doing everything right. One of those things where you just question the logic of everything. Tried every option a 100x. Since it was responding to hardware serial with an error flashing the yellow every half second I made the assumption the PIC was powered. I checked every other trace a 100x. I think with the feed back on the hardware serial it was giving it enough power to start then when communication began it reset.

I decided to check voltage to make sure it was where it needed to be an there was a missing section in the trace to power the PIC…Dumb dumb dumb.

Anyway, from there it worked fine hardware or software serial.

I am glad you figured out what was wrong. Thanks for letting us know what it was.