6 Bit Servo Controller - Errors 0x1f and 0x16

Hi everyone,

I recently acquired the 6 bit Pololu Maestro Servo Controller. After having soldered all the connection points, I also soldered a wire from Vin to PWR (picture attached) in order for the connected servos and the servo controller to be powered by one power source.

When I plug it into my PC via USB, it registers instantly and can be connected to. However, when I plug in the power (the lights go on) and connect it to my PC, it constantly connects and disconnects from the Pololu Maestro Control Center. Two errors pop up when I try to manually select it; 0x1f and 0x16. Attached are screenshots of the full error messages.

I am currently using a Turnigy 20-30C 2200 mAh Li-Po battery (11.1 V).

What am I doing wrong? Any help you can provide would be greatly appreciated!


I am sorry you are having trouble getting your Maestro working. Can you post some pictures that show how you have your Maestro connected to everything (including any servos) when you get the error? Do you have a different USB cable you could try using and, if you are using a hub, could you try connecting without that?

Also, many of your soldered joints look like they might make unreliable connections. You might look at the Adafruit Guide To Excellent Soldering to see how to identify common soldering problems and for tips on making a good solder joint.


1 Like

Hello Nathan!

Thank you for your reply!

Thank you for the soldering tips! I will take a look and try to rectify my soldering. However, I don’t believe that the soldering is the issue, as I have managed to create a sequence “blind”, as the Maestro works when I plug it into my PC without the power source. I created a test program, made it loop and run on start up in a script, unplugged it and plugged in the power source. The script worked fine (servos were functioning properly). Connection pins 2 and 3, however, did not seem to function, but I suspect it’s due to my bad soldering skills as you pointed out.

Thus, the main problem is that I cannot plug in my Maestro into my PC while it is connected to the power source. I have tried plugging it into my PC, establishing a connection and then plugging in the power source (I understand that this is bad practice, but since the reverse didn’t work, I wanted to try it out) but that didn’t work either. Here are pictures as to what is connected to my Maestro when I try to connect it to my PC (without my power source attached as the script is set to start on power up):

And here’s a video showing the test sequence working with the servos:

I am not connected to any hub; my Maestro is connected directly to my PC’s USB port.

Edit: I re-soldered the pins and pins 2 and 3 are now fully functional! Thank you for the links and tips for soldering! However, the main problem where I cannot connect my Maestro to my PC while also powered by a power source has still not been fixed by the re-soldering.

1 Like

Thanks for the additional pictures. Do you get the same errors if you plug the Maestro in to the computer with the battery attached, but no servos? What kind of servos are those? A 3S LiPo is generally too high a voltage for most standard hobby RC servos.


Hi Nathan,

I do get the same errors when I plug in the Maestro with the battery attached and with no servos. It constantly connects and disconnects from my computer.

The servos are hex Tronik HX12K Hi-Speed servo motors. Taking a closer look, I see that the voltage from the LiPo is indeed a tad higher than the operating range of the servo motors. But that can’t be the reason for the errors, could it? I get the same errors even without the Servos attached.

Did you try another USB cable already? If not, do you have one you could try to see if the behavior changes? If the controller behaves the same way with a different USB cable, could you contact us via email (support@pololu.com) with your order information?


I don’t have another USB cable, but I will be heading into town to get one today. I will also attempt to use a battery pack with 4 AA batteries (6 V total) to see if that changes anything. Will update ASAP! If that doesn’t work, I will contact the email you provided.

Thank you again for all your help Nathan!

EDIT: After having gotten the battery pack, my Maestro works with my computer! It seems the LiPo really was the problem after all. Thank you again Nathan!