4-25v boost regulator outputting 0.6 ~ 0.7 volts

Tested with a load on the output and can only measure 0.6v on the output. Adjusting the potentiometer does nothing to the output voltage

I’ve verifyed the input voltage is 5 V and it still not getting anything, it’s not get hot either

I hope it’s not broken as it’s my 3rd one I have bought now and had no look with any boost regulators



I am sorry to hear you are having problems with your adjustable step-up regulator. Just to clarify, can you confirm that you’re referring to the #799 Adjustable Boost Regulator 4-25V? Also, have all three that you’ve had problems with been that same product?

Could you post some pictures of your setup that show all of your connections? What are you using as a load, and have you tried measuring the output without it connected?

As noted on the product page, applying an input voltage that is higher than the output voltage is set to can damage the regulator, so we recommend using around (or below) 2.5V when setting the desired output voltage. Did you follow that recommendation or have you used 5V the whole time?


Yeah it’s item #799

I have only be tested with 5v and I was trying to get the voltage without a load at first but then I read about the 10k ohm load so used a small DC motor, but no mater what I only got .6v

So I bought this on Pihut.com and it does mention the 2.5v input to get to get the desired output voltage set but it’s buried quite deep in the description. I’m going to see if I can get a replacement, if not hopefully let them know to make it a bit clearer for those in the future