3pi switches on when batteries added and doesn't turn off

I have a 3pi robot. When batteries are added it powers up. It does not respond to the power switch at all.

We have 2 x 3pi robots the other is working fine.

I have confirmed using a multimeter that pressing the switch creates a circuit. But now I don’t know what to do beyond this.

We are preparing for an industry (us) teachers (them) robot racing contest on Tuesday, it will be a bit of a flop if we can’t get one of the robots rolling.

This 3pi has worked in the past by the way it has been in a box for 6 months but before then it was working.

Any advice.

Kind Regards

Johnny Read


If I understand your post correctly, your 3pi is always on, right? I realize that’s not ideal, but if that’s the case and you need the 3pi working right away, it should at least not impact your use much: you should be able to use one of the buttons to trigger actual running and another button or the reset button to stop a robot that is running. It’s crude, but you can use insertion and removal of the last cell in the battery holder as your power switch.

As for the actual issue, the MOSFET used for the power switch circuit might have failed with a short. Do you know anything about what might have happened to the 3pi between the time it was working 6 months ago and now? Before we go down the path of determining which part is damaged, do you have the equipment and skill to replace something like a 6-pin SOT-23 component?

- Jan


thanks for getting back to me. We are running the 3pi with an MBed expansion board, making it difficult to remove the batteries. Given the tight time constraints we are under we have purchased a new 3pi (although unlike our other 2 robots this didn’t have the connectors for the MBed fitted as standard, a change in specification perhaps.)

Our technical skills are limited to a multimeter and some limited soldering, I’m doubtful we could deal with a tiny surface mount component, if that were the problem. Although we are open to suggestions.

As far as we know the 3pi went away in it’s box working and came out with the power problem. I must assume that it has suffered a knock, static or temperature problem of some sort, apart from the power it seems to operate as expected, (without the MBed board.)

Any thoughts?

In order to allow the MBed processor to be connected I soldered on some connectors. I’m now wondering if a short in one of these could be causing the problem. Having me near it with a soldering iron is likely the most dangerous thing that has happened to this robot and hence the likely cause. I’ll update when I’ve checked.

I had a careful look at the soldering of connectors, one of the joins for the power connector appeared connected to an adjacent connection. I removed the solder and this solved the problem.

The attached image shows where the spill over was.

Great; thanks for letting us know what the problem was!

- Jan