Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

3PI Setup Help! Ubuntu, avr problems



I am hoping someone might be able to offer a little help on getting my 3PI setup through ubuntu linux! I’ve read the instructions on 2.a & 2.b, and have gotten eclipse to be able to compile my c++ code, however the problem I am having is actually downloading the code to the Robot!

Using avrdude, when I attempt to download I get the following error window pop up:

I’ve made it this far. Does anyone have any advice on what to do?



Hello, Ian.

I am sorry you are having problems with programming your 3pi. Which AVR programmer are you using? Can you run ls -l /dev/ttyACM* and groups in a terminal and post screenshots of the outputs here? (Those commands will help us check that the serial port exists and that your user has permissions to access it.)

- Amanda



Here is the screen shot as you requested

The AVR programmer I am using (pretty sure, im new to programming and linux) is named in Eclipse as “AVR Eclipse Plugin Version 2.4.1”.

Noticed that when I did the ls command line you suggested I got two ports there, I entered into the project–>properties–>avr–>AVRDude–> hit edit on the programmer configuration box, and changed the ttyACM0 to ttyACM1, and when I applied and tried to download, I got the same error as my first post, just with the ttyACM1.



It looks like you entered the second command wrong. You used the number one instead of a lowercase ‘L’. Can you try running ls -l /dev/ttyACM* in the terminal again and post a screenshot of the result?

By the way, it seems like you are using our Pololu AVR USB Programmer or our Pololu AVR USB Programmer v2. Please note that /dev/ttyACM0 is the programming port for both of our AVR programmers and /dev/ttyACM1 is the TTL serial port.

- Amanda