3Pi error Problem Help Pls


My 3Pi Robot just arrived last week from Pololu. I installed Atmel 6.2, as well as the AVR Programming drivers and C/C++ AVR Library.

I can build the program successfully, but when it comes to loading it onto the device I get an error, ‘Launched has failed and Studio could not read the target voltage. Please check your connections and try again.’

Given that the Robot is brand new, I am doubtful that the connection is poor (albeit still possible). Before I go out and buy a brand new cables etc., can someone help me with a possible other solution?

I have looked up this issue on the net and not many people post their final solution. One solution involved loading the .hex file from the ‘memories’ tab in the device programming menu. the default file is the .elf file, and I change that to the .hex but it still gives the same error.

The 3Pi must be powered up, with fresh batteries, in order to be programmed. Is that the case?

Yes I have tried two sets of fresh batteries.

What programmer are you using?
Is it possible that the programming connector is inserted backward?
Did the 3Pi run when you first turned it on?


The ribbon cable and usb cord can only be inserted one way because of the way the terminal shaped. It has not been inserted wrong. It also runs the demo program which is loaded at the factory when the unit is turned on. Please I still need help.

I am using the AVR programmer

There are many, many “AVR programmers”.

I have 6.1 but i’m sure it’s similar.

how are you trying to upload the program ?
have you checked out what COM port the programmer has and have you gone into the tools menu in the studio and added a target?
then in device programming (same menu) have you selected that tool and clicked the apply?
can you simply read the device signature and voltage (buttons at the top on the right).