3pi debug problem

So i just finished the installation of the 3pi robot and opened atmel 6.1 for a test. I tried to debug the demo code using F5 but i got this error ( imgur.com/QkAyIGI ) . I chose the right model/ the right port (COM) , the 3pi robot is connected…what is the problem?


Can you post a screenshot of the “Available Tools” window in Atmel Studio and a screenshot of the Windows Device Manager with the “Ports (COM & LPT)” expanded?


I tried with both COM4 and COM5, it still doesn’t debug. I believe it has something to do with the “Pololu AVR USB Programmer”, i read in a guide that i need a version “>” than 1.07, and my version is 1.01. How do i fix it? Thank you for your help! imgur.com/alYWzMA

I have firmware version 1.01 -> imgur.com/sBRXK2i

You can upgrade the firmware to version 1.07 using the instructions under “Upgrading Firmware” in the “Upgrading Firmware” section of the “Pololu USB AVR Programmer User’s Guide”.

After upgrading the firmware can you try programming using the “Device Programming” option in the “Tools” menu? Once you have selected the tool (STK500 on COM5) and device (ATmega328P), click the Apply button. You can then click the “Memories” menu on the left-hand side and the “Program” button to start programming. If you get any errors, please send me a screen-capture of the errors.


It’s working! Thank you so much!