3pi+ 32u4 not working with arduino on linux mint

I am using a linux mint computer in an attempt to program a pre assembled 3pi+ turtle edition 32u4 robot using the arduino ide v2. I am ale to recognize the device, the port, the device type, and i run “sudo chmod a+rw /dev/ttyACM*” before attempting to upload, I have restarted my device multiple times and every time i try to upload i always recieve the same error message

avrdude: ser_open(): can’t open device “/dev/ttyACM0”: Permission denied
Failed uploading: uploading error: exit status 1

I have no problem uploading to standard arduino boards such as the uno or due as long as i run the command i mentioned before i upload, can anyone help me get this working

Manually changing the permissions like that works for some Arduino boards, but not ones like the 3pi+ 32U4 Control Board that are based on the ATmega32U4 because it disconnects and reappears as a new device when you upload. Instead, I recommend determining what group those serial ports are in (e.g. using ls -l /dev/ttyACM* ) and adding yourself to that group.