3pi+ 32U4 - not visible in device manager

Hello guys !
At our school we just got a new 3pi+ model.
Upon working with it the students tried uploading a code on it and since that moment the board/robot is not visible when connected via the USB. I am unable to see it anywhere in the device manager - it doesn’t react at all when I plug it in. Tried different computers, tried different cables - nothing happens.
Installed drivers: A-Star
Any help would be appreciated !


I am sorry to hear you are having problems with your 3pi+ 32U4 robot. When you connect to USB, does the green power LED next to the USB connector light up? Could you try double pressing the reset button (i.e. pressing it twice within 750ms) to put the 3pi+ 32U4 Control Board in bootloader mode while monitoring the Device Manager and see if it is recognized while that’s happening? It should stay in bootloader mode for 8 seconds after you double press the button, and during that time you should see the yellow LED fading in and out.


1 Like

Helllo BrandonM ! Appreciate your fast reply.
Upon connecting it to the USB - the green LED next to the port lights up and the red LED next to one of the buttons (says RX under it) lights up.
Tried double pressing the reset and indeed the yellow one started flashing and for a brief moment I was able to see the robot in the COM ports but as soon as it stops flashing - it disappears.
Any further help would be appreciated.

Edit: found this in the support, gonna try it a bit later:
Resetting the board twice within 750 ms makes the board go into bootloader mode. The bootloader will exit after 8 seconds and try to run the sketch again if it has not started receiving programming commands. To revive the device, you need to make sure you start sending it programming commands before the 8-second period is over.

In bootloader mode, the yellow LED (the one labeled LED 13) fades in and out. It is useful to look at this LED so you can know what mode the microcontroller is in. Also, we recommend enabling verbose output during upload using the Arduino IDE’s “Preferences” dialog. Looking at the LED and looking at the verbose output during the following procedures will help you understand what is going on.

Edit 2: Yep, during this 8 second window you can start uploading a new sketch and it’s all good now ! Robot already following a line. Thanks for the help :wink:

I’m glad you were able to get it up and running again! Thank you for letting us know.