Works fine when connected via USB, Red light when not

Im just doing some premlim tests with a mini maestro 12, and put together a very simple sequence triggered by a button push. I saved the script to the board and all works fine when the USB is connected, but if i disconnect the usb and run it from the internal script and PSU, sometimes its good, sometimes it just flashes red, sometimes it does 3 or 4 cycles then goes red.

Now what I think is happening is the PSU is a switch mode which powers the servos fine but is scrambling the data to/from the chip?
I also noticed it does the same thing if I run it from a 4.8V battery (because it needs 5V) works fine from a 6V battery but as the battery got flat it does the same thing. So its struggling to get clear signals due to insufficient voltage/dirty current?

  1. Am I right?
  2. Would using a linear PSU solve this? Does anyone still make these? (Im UK based)
  3. Is there anyway to hoodwink the SMPS to work, as in smoothing capacitance? (What value cap is advised, and how would I work that out for myself in the future?)
  4. Is there such an object to boost a 4.8V battery up to 5V+? anything small?

Many thanks!


The most likely explanation is that your power supply cannot really handle the sudden surge in current when the servos start up, and the voltage drops, which triggers a brownout reset on the Maestro. If you have an oscilloscope available, it would be useful to look at the voltage on the Maestro’s VIN line to see what it does when the servos start. Also, the Maestro should blink its red LED a few times after the brown-out reset occurs, so that would be good to look for.

I don’t know if anyone makes linear PSUs and am not sure if that would solve your problem.

You could try connecting a capacitor of 100 micofarads or so between the Maestro’s GND and VIN pins, near the Maestro. I don’t have a formula for how to calculate that capacitance; this is just based on experience. Adding more than 100 uF wouldn’t hurt.

We have some regulators that can make 5V from a 4.8V input. In particular:
You could use these to supply power to the Maestro’s VIN pin, but they are not suitable for powering servos.

How long are the power leads from the PSU to your system?


Hello David
Thank you for your reply.
I ordered the smaller 5V regulator which is a lovely simple little thing. Ive borrowed 4.8V from the pin next to the servo power input pins, that is designed to work with the jumper, but Ive detored it via the regulator then into VIn and ground on the left side for the chip.
Ive also managed to get the sequence to trigger via the IR sensor as I intended. But its still not quite right. For a reason that is completly baffling to me, the sensor/script etc works perfectly when hooked up to the computer, triggers every time I wave at it, but when i disconnect the USB it barely works, it triggers maybe 1 out of 20 times. No error red lights, but it just doesnt trigger nearly as cleanly. Any ideas?

I would try to simplify the system as much as possible and find the simplest configuration where the problem happens. For example, if you disconnect all the servos, does it still happen? Once you have the simplest configuration, you could post a complete description of it and we might be able to see what is going wrong. You can turn the red LED on from your script in order to help with debugging, and you can use a multimeter to verify that various voltages are what you would expect.