Wixel EAGLE library

after moaning and groaning all day
I offer an EAGLE library for the wixel

wixel.zip (1.69 KB)


Thank you for making the Wixel EAGLE library, we probably would like to post it as a resource on the Wixel product page (with your permission). I have a couple of recommendations/comments for improving it:

  • VALT is missing from the schematic
  • Adding an indication for how far the USB connector sticks out over the board edge would be helpful
  • The drill holes are set to 31 mils in diameter, which might be too small

- Ryan

sure thing
I’ll make those changes now
I missed VALT and looks like I added P0_6 instead

be right back

and here’s Mk II

a) VALT added :smiley:
b) P0_6 removed :blush:
c) holes now 40 mil
d) GND holes now square
e) USB connector shown just peeking over the edge of the board
f) box added to show location of uProcessor
g) signal pins are now swap level 1 so you can swap them!

if you spot anything else - let me know

please do add to resources if you think it’s useful :smiley:

wixel.zip (1.74 KB)

Sorry for not replying sooner, I was out of town for a while. I just got a chance to look at your Mk II version. It looks like only the hole size for the top-left GND hole got increased to 40 mils while the other ones are still around 31 mils.

- Ryan

thanks for the feedback
be with you shortly!

ok try this one
(I really thought I’d sorted that)
wixel.zip (1.72 KB)

Thanks for fixing that, it looks good to me now. We have it up on our resources page for the Wixel. Thanks again for making this!

- Ryan


I just tried to import; this Wixel.lbr file into DipTrace Component Editor and got an error as shown:

Screenshot 2022-02-04 201944

When I tried to look at the file in Notepad++ it was pretty obviously not an XML file. Am I missing something? TIA


Apparently this user-supplied library is in binary format, which DipTrace cannot handle. Could I get someone to open this in Eagle and re-save it as an XML file?



Hello, Frank.

It sounds like you found a solution to your problem; for anyone else who comes across this post, please refer to this thread instead.