hello again,

I am finally sending my VNH3SP30 (30-amp motor driver board) the right pwm signal. Right now i’m using a 5KHz signal at 50% duty cycle, with no luck.

I verified all the connections, and I see ‘high’ on pins INA, DIAGA, DIAGB and a ‘low’ on INB. 5.0v for the VNH3SP30, 7.2v at the motor supply leads.

This is the weird part: I see 0v at the motor with OUTA/B connected, but if I disconnect my motor from the OUTA/B, I see 7.4v! SO it seems the hbridge is working. I tried switching motors, and equal ones didn’t work (hobby car motors), but when I hooked a 1.2v baby motor up it worked. I thinking its a current (amp) problem, because a finger-short drops the 7.4v motor lead to 2v. I replaced the leads with 14 gauge copper wire and changed batteries. Still nothing with the motor connected. (hooking the battery right to the motor spins it good, so the battery should have the juice.)

What could be limiting my current to the OUTA/B terminals? If that is the problem. I removed it from the heatsink and I don’t see any burnt components on the board, and the traces look good.

Even when I send it servo-pulses again, which used to work (albeit noisy), it still doesn’t turn, so I don’t think the pwm signal isn’t the culprit. Have I gone and broke the board?


If you are not sure about the state of the motor driver, keep the PWM line high to turn on the motor completely. Try both directions since just one of the legs in the H-bridge could have broken (we’d still need to replace it, but at least we would know what is going on).

Also, see what the diagnostic lines are doing. The motor driver will shut off if it detects a short, and the motor could be too big for the controller. I’m not sure what you’re using, but a 540-size motor is generally too much for this driver since the stall currents are on the order of 100A. Do you have an intermediate motor you can try?

If you still can’t get the motor going, you can send it back to us so that someone can take a look at it here.

- Jan