UsbWrapper does not exist in the namespace


I installed the Maestro Servo Controller sdk. I’ve recently downloaded Visual Studio Express 2013 and have used it to compile and run other programs. I get the following error when I try to run MaestroEasyExample -

“UsbWrapper does not exist in the namespace ‘Polulu’ (are you missing an assembly reference?”
‘Pololu.USC’ is a namespace but is used like a type
The referenced project ‘…\Usc\uSC.CSPROJ’ does not exist

Also, I notice under the References tab, UsbWrapper and Usc have alert symbol next to them (yellow exclamation signs)
Double clicking either pops up a window that says "This project cannot be viewed in the object browser because it is unavailable or not yet built. Please ensure that the project is available and built.

Please advise.


Hello, Robert.

It sounds like you downloaded the Pololu USB SDK and are having trouble compiling MaestroEasyExample. I just tried compiling that example with Visual Studio Express 2013 for Windows Desktop and it worked. It would help if you could provide the exact error messages you are getting. Could you copy and paste them from Visual Studio or take a screenshot?

Also, could you click on the UsbWrapper reference and investigate it to see what is wrong? It would help if you could resize the “Properties” pane so that it is big enough to display the full value of the Path property, and then take a screenshot of the Properties pane and post it here. The Path property should point to UsbWrapper_Windows/UsbWrapper.dll in your copy of the Pololu USB SDK. Does that file exist?


Hi David,

Thanks for the fast response. I downloaded the sdk again and no longer getting the UsbWrapper reference error. Originally I had just downloaded the folder for MaestroEasyExample as I guess you suspected, the referenced file was not there. This time, I downloaded the entire folder with all the projects and now the reference error is gone.

However I’m still not able to get it to work.

Two things happened on my second attempt -

  1. When I first opened the solution, .NET migrated some files and generated the attached migration report.

  2. When I try to compile, the following error -

"A project with an Output Type of Class Library cannot be started directly.

In order to debug this project, add an executable project to this solution which references the library project. Set the executable project as the startup project."


Migration Report_htm#Solution.htm (84.3 KB)

Hi David,

I found the answer - All I had to do was right-click one of the projects within Solution Explorer and select “Set as Startup Project”