USB16 servo controller problem

I’ve been having some problems with the pololu USB servo controller. I can use it without any problems on one computer, but there is another computer that it doesn’t work on.

The failure mode is when I try to communicate with the device, the serial transfer seems to work, but then the red light flashes and no servo action occurs.

The setup on both computers is the same. Both have installed the USB driver, both have the pololu device as COM5, and both are running the same code. In the BIOS, both of them have the same USB setup and the same serial UART setup. The pololu device is in pololu mode (jumper removed), and the first command that gets sent to it (which causes it to flash red and not do anything) is an absolute position command going to servo number 0.

The command being sent is the same on both computers, but it works on one and not on the other.

Does anyone have any sage advice for me?



I hate it when something works perfectly well on one computer and not on another!

I don’t have any real sage advice other than that something is wrong with the bytes that are being sent to the servo controller by the second computer (says Captain Obvious).

A blinking red LED indicates a fatal communication error, which means either something is interfering with the serial communication (not a big possibility here, unless you’ve got a tremendously long serial cable) or that the format of the communication is somehow unacceptable (inverted, switched to a new baud rate, etc…).

What happens if you try to manually send commands to the controller from a terminal program? I would try to get it working on computer 1 (the good one), then try the same thing on computer 2 (the bad one). My guess is that somehow the virtual serial port is being being configured other than the way you want it. What OS are you using? Does your program override the default configuration of the virtual com port?

Of course an oscilloscope would be the ultimate way to check out the bytes you’re sending, I don’t suppose you have one lying around?

Sorry to answer with so many more questions.


Thanks for the hints.

I’ve tried using a terminal program to send commands, and it works fine on the good computer and not so fine on the not so good computer.

Both computers are windows XP. The good one is a desktop P4 3.0G. The bad one is a small form factor (in car PC style) with core2 duo. Might be something to do with USB support on the small form factor motherboard I suppose. I can get mice, keyboards, and even USB Digital video capture devices to work on the bad PC, but it just doesn’t seem to like the pololu board for some reason.

I’ve tried with no other USB devices connected, and I’ve tried it through a USB powered hub, all to no avail :frowning: I guess this one has to go down as an unsolved mystery.