USB-to-serial adapter problems

i just buy an Pololu USB-to-serial adapter and it not work.
i installed the driver supplied from this site[[[ (293k)]]],and i manage to change direct from that driver the com3 to com2 , but i left it to default in the end. (i ensure you that my driver is installed ok).
i link-it to Pololu’s Micro Serial Servo Motor Controller.(at MSSC all 3 leds are ON-no blinks). And my UTS (USB-to-serial) have a red led [ON] ALL THE TIME(except when is not have supply).
i use the software VSA(visual show automation) to manage to transmit data in MSSC and to make a Futaba servo motor run. (i manage to make it run without this UTS (USB-to-serial) but now im stuck.)
how i managed to make running the MSSC and servo motors see at: Assistance for running servo motor(futaba)
***the connections:
i use a USB cable A to mini-B-like this:
i connect the TX(out+) from UTS to "RS-232 serial input(+)"from MSSC and i linked together the two grounds(-). (if you want to see where is located this “RS-232 serial input(+)” in MSSC follow this link … xamle1.jpg
and imagine that serial port is in fact my UTS)
all good.
***running the software (VSA) my 3leds from MSSC working like this:
when i choose 9600 baud rate the yellow led blink and the red one is ON.
other value make the red one blink and the yellow led is ON.
only at 115200 baud rate the green led blink faster and the red led is ON.
-my serial port at the motherboard (COM1) is still not working (though i manage to RECEIVE some bits with a infrared remote control and a adapted electronic circuit). working i mean it DONT TRANSMIT ANY KIND OF SIGNAL. i verify this with an oscilloscope and compared a good COM1 from my father computer with this bad of mine.
i make a test even at father computer with all this UTS (USB-to-serial) and MSSC and dont work there either. same problems like my PC (i mean the leds are blinking the same).
***suggestions? :slight_smile:
sorry for this veeeeeeeeeeeeery looooong script but i want to make it RUN.
faster,better,stronger - like a axiome in some old RTS game.
may the GOD here my prayer. :slight_smile: :slight_smile:

The Pololu USB-to-serial adapter outputs 3.3V level serial, not RS-232 level, so you should connect TX from the adapter to the “logic-level serial input” pin on your servo controller. You can connect the grounds any way you like.


nexisnet you are a bless for those in needs :smiley:
thank you very much -it worked !!! .
huh ! a very big stone from my heart is lifted now.
thank you very much for your support.