USB orangutang Drivers not installing on MAC

I am trying to get the drivers to install on my Mac.

i am getting the Drivers from

I go through the process of installing the drivers, before anything is installed i get prompted to restart or shutdown.
After the restart nothing is installed and USB Orangutang still not working.

Thanks for help

Might it be because i am running 10.6?


We cannot provide much support for the Mac right now. But if you want to get some help, you should at least tell us what product you are trying to use on your Mac. A specific product number or a link to the product web page would help clear this up.


Well i have been trying to program my 3pi Robot on my mac. and am running into issues.

I am trying to do it through the Arduino IDE.

In configuring it,

i got through every step but when selecting the Serial port in the Arduino IDE, there is no COM port.
and i am assuming that it is the USB orangutang is installed correctly, but i am not 100% sure.

I am using the USB port but am getting an error.

I will post the error as soon as i get back to it, ive had to reconfigure my Arduino a few times for different projects.


You’re still not identifying the item you are plugging into your USB port. We have had several revisions of our programmers, and we don’t know which one you are using.

- Jan

Hey Sorry

i am using this

Hope thats what you needed.


You are using the Pololu USB AVR Programmer (product #1300), but the instructions you linked to earlier are for a different product. The USB AVR Programmer is, unfortunately, not supported on the Mac, as it says on the product page.

Do you have a Windows computer that you can try using with your 3pi?


Ahhhhh that makes much more sense now… alright then yes i am going to see about getting my hands on a PC to get the 3pi set up.

for future reference what hardware will i need to program my 3pi on a mac?


Michael Shimniok, one of our customers, wrote a tutorial on programming Orangutans from a Mac that you might find helpful. I believe he used our original programmer, the Orangutan USB programmer, which uses the CP2102 USB-to-UART bridge and has drivers available for the Mac.

Good luck getting everything set up! Please let us know how it goes.

- Ben

Edit: here is the origial thread about programming Orangutans from the Mac, in case you’re interested or want to post some comments there:

Edit: Note, I had the PGM02B, not the PGM03A

I wanted to take some time to share some of the things I encountered when attempting to use the drivers I downloaded.

I’m running Mac OS X 10.6.3, 64-Bit.

I started off with the drivers from here:

I found that the drivers were not being loaded on my system. I checked out to see if the drivers were loaded by using:

ls /dev/tty.*

from the OS X Terminal. If you see “/dev/tty.Pololu” everything is installed, if you don’t then you are probably seeing what I was.

Some further investigation into the error console lead me to find this:

May 15 21:53:31 Christopher-MacBook-Pro[10]: Can't read info dictionary for Pololu.kext: IOCFUnserialize: syntax error near line 3.
May 15 21:53:58 Christopher-MacBook-Pro[582]: Can't read info dictionary for Pololu.kext: IOCFUnserialize: syntax error near line 3.

Some hunting around I actually tracked down and opened the plist located in the Pololu kernel extension and found that it was not properly formatted.

Here’s what I found in the driver’s Info.plist:

<?xml version=\"1.0\" encoding=\"UTF-8\"?>
<!DOCTYPE plist PUBLIC \"-//Apple Computer//DTD PLIST 1.0//EN\" \"\">
<plist version=\"1.0\">[/code]
A proper plist should start with this:
[code]<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "">
<plist version="1.0">

For some reason, the driver wasn’t properly formatted and had escaped quotation marks in the XML file, and when OS X attempts to read the extension, fails because of the format.

I found that I could actually fix the kext. Here are the steps I performed, unfortunately they’re all on the command line:

sudo -i
cd /System/Library/Extensions/Pololu.kext/Contents
sed 's/\\\"/\"/g' Info.plist > tmp && mv tmp Info.plist
cd ../../
kextload Pololu.kext/

The idea of the commands here are to Switch to root so we can actually change the PList without errors, do a Search and Replace on the PList and fix the escaped quotes, then load the kernel module. Then logout of the root session.

Hope the original poster hasn’t given up all hope and comes back to this thread. If not, hopefully someone else will stumble upon this fix.

P.S. Who ever at Pololu made the drivers could easily fix this problem.


Thank you for the information. Hopefully other Mac users will find this information helpful. The CP2102 drivers are from Silicon Labs, the manufacturer of the USB-to-UART bridge, not from Pololu.

- Ben

Hello Ben,

The CP2102 drivers available from your website are customized in some way from the default Silicon Labs drivers. I think they’re built with a custom installer and using your own PID for the USB driver.

Also they’re built with your manufacturing information in drivers, not Silicon Labs.

<string>Pololu Driver version V1.02.2</string>
... Snip...

Someone has done some customization to the drivers, however, they don’t work properly anymore

For the Windows driver, we just put in a few things like our name and the product ID Silicon Labs gave us into a driver generator they provide, and we haven’t changed anything in a while. For the Mac driver, I think we don’t even have access to any driver generator, and I think they just gave us this customized driver.

- Jan

This fix for changing the " to " in the plist header was exactly the trick. I tried to get these drivers to work for a couple hours now and stumbled upon this by googling. Thanks! Please get SL to fix the drivers they sent you so people don’t waste time! I am on Mac OS X 10.6.4 on a MacBook pro Intel core 2 duo. (2008 model).


OK… So I’ve got the USB to serial bridge installed and can see /dev/tty.Pololu.
When I run the Java Hello world program found here: … _converter

I get:

Found port /dev/tty.Pololu
Port in use.

and I cannot write data to it.

do I have to “short” some of the status pins on this adapter, like in a null modem cable where you cross rts and dts, etc…

Any hints would be great


That makes it sound like you have some other program running that is using the port. Is that possible?


I got it to work!

I’m using the RxTx serial drivers for Java and found a post here: … on-on.html

You have to add a lock file dir on OS X for this driver.

Open a terminal and do the following:

  sudo mkdir /var/lock     (hit enter end type your password)
  sudo chmod 777 /var/lock   (hit enter again)

Now that it’s working… I am not having success communicating to my pic-servo chip. To test the functionality of the usb to serial, shouldn’t I be able to connect it to a Serial LCD (like a Scott Adams Backpack) at 9600 baud and send “hello world” to the LCD?


Maybe. Have you tried it? Can you specify exactly what device you connected it to, how you connected it, what test you did, and so on?


I connected it to one of these:

and have a 4 line LCD hd44780 based lcd connected to it. When I power it on, The LCD displays verion info of the controller backpack. But when I send data “Hello world” from the LCD, it does not work.

The controller backpack is for converting rs232 INVERTED TTL levels.

I fear that this usb may not be sending inverted line levels… That is… a 0 is 5 volts in Inverted TTL.

Is there any way to open a serial port with inverted logic?