Usb 16 -servo controller - baud rate problem?

I recently purchased the pololu usb 16 servo controller and I am having trouble communicating with it from my computer. I have it connected using a usb cable. The software driver installed successfully and I am able to see the device in the device manager (WindowsXP). Also, I can see a couple of lights blinking (I guess it is initializing) and then I see solid green (usb active) and the solid yellow (waiting for data) lights which i guess is expected. But when I try to send data to the controller, I always end up with a solid red led and a blinking yellow led. In the user guide, this is diagnosed as serial rate too slow. I have tried serial rates from 9600 up to 57600 with the same result. This happens in both Pololu and the Mini SSCII mode. I am using a C# program to send the following byte pattern {0x80, 0x01, 0x00, 0x00, 0x40} which in Pololu mode should turn on servo 0. As soon as 0x80 is sent I see the red led turn on and yellow blink. The serial port settings that I use are
baud: 9600 - 57600 (ive tried different nos here)
Parity - None
data - 8 bits
Stop bits - 1

Am I doing something wrong here? Do I need to use any flow control? Do I need to send a particular sequence before I can send the commands? Is there a simple software i can download to test the controller board in windows (test be board with hyperterminal?). Any help to get past this problem is greatly appreciated.

Thanks in advance!


It sounds like you understand the servo controller correctly. Is there something you can do verify that you are sending the correct data and at the correct baud rate? If you have an oscilloscope, you can look at the serial data at the logic-level serial input pin.

We test all units before they ship, but if you want to check to make sure your servo controller is still okay, you could download some software available for Mini SSC II compatible controllers. For instance, has a demo version that you could try (make sure you have the shorting block on!). If that works, then there is something wrong with your software. You don’t need any flow control, and all your other settings (that you mentioned) are correct.

- Jan

Hi Jan,

Thanks for the reply. Unfortunately I do not have an oscilloscope handy with me. I have tried the VSA demo and the MiniSSC test software - but I am seeing the same results. Is there anything else I can try?


I’m not sure what’s causing your problem, so I think you should return the unit you have. Please give us a call to arrange for a new unit to be shipped out to you.

- Jan

Hi Jan,

I just got the replacement and this controller works great. Thanks for helping resolve the issue. You guys are awesome:)


I am having the same issue as David had, but I have tried the controller on different computers. On my professor’s computer it works. On my groupmates it worked once, the next time we tried the red led just blinked, and that was what it was originally doing on my computer. I have tried reinstalling the drivers on both of our computers. Now on my computer the red light turns on and the yeloow led blinks. On my prof’s computer we hooked it up to an oscilliscope (after running it to an amp) and it would only go from +12 volts to -12 volts, nowhere in between. We are using Colin Karpfinger’s example program for now just to try and understand it better. All of my inputs are the same as David’s. Any suggestions?

Also, just reading through some other posts, and I noticed you said you are rather rough on these microcontrollers and you don’t seem to have any problems. Have you ever had any troubles with EMI? We have used a couple of different power supplies (the led problem happens with or without a power supply hooked up, on the different computers) and one of the power supplies we have used, when turned on or off will make the microcontroller flip out and we have to reboot it, but it worked again after that so I don’t think it did any damage, but I could be wrong. have you ever had any issue with that?

Hello. If you saw your unit working, I’m a bit more skeptical that it is defective. Does it still work on your professor’s computer? What was going from +12 to -12 V? The “flip out” episode is also a bit concerning; what kind of power supply did you connect to what? If it’s a cheap power supply, it’s possible that it goes through some bad transients as it turns on, which could damage the servo controller. We haven’t heard of any particularly noteworthy noise problems with these, especially since they typically have their own power from the USB port.

In any case, if you continue being convinced that the unit is defective, you can send it back for us to look at.

- Jan

I am pretty sure the power supply was not even connected the first time we turned it off. And it was sitting 2 feet away from the microcontroller. It was a nice commercial power supply too. But I think we will try and send it in.