Trying to figure out if 18v15 driver is dead


I’m using an arduino with a simulink interface to control a thermoelectric with the 18v15 motor driver. It worked during my initial setup, but when I finalized all my wiring, the driver was no longer responding.

The driver is being powered by a +12V line from an ATX power supply that first goes to a bus bar. The bus bar also supplies two 12V cpu fans. Arduino is being run from simulink instead of the normal IDE. The driver is only receiving dir from pin2 and PWM from pin3, but I’m not entirely sure what the underlying code does.

None of the faults are high, but the 5V line is low. All the other logic side lines are as expected (Vin=12V, RESET=5V). The large capacitor is installed.

Is it fried or am I missing something?


If the 5V line is low, then the driver is probably damaged. What specifically changed between when the driver last worked properly and when you noticed it not working? Were any of the components powered while you were changing your wiring?

- Ben

I unsoldered two leads that had been connected to Vin and gnd on the logic side. The wires weren’t connected to anything, just taped off till I would check them with a multimeter. The system wasn’t powered when I did it.

Most of the rewiring had to do with connecting a bunch of other sensors to the arduino, adding terminal blocks for gnd, 12V, and 5V lines for the whole system, and then wiring everything to a panel mounted connector.

I’m thinking I either flooded the chip with too much heat when I did the unsoldering, the voltage spiked when the power supply turned on, or there were ESD issues.

Gonna have to buy another. It’ll be the last thing in the system that I touch.