Trex JR - Error loading the trx file


I have a TReX JR controller hooked up to a COM port on my PC, which was previously working successfully with the Configurator Utility V090923.

For my real application I need to communicate with it using a microcontroller at 38.4k, so having read in the instructions it would require a firmware upgrade to v1.2, I attempted to do so using the trexjrv1_2.trx file from the website. I placed the board into the bootloader mode following the instructions, however when I hit the “Program” button, after erasing the flash it responded with the message “Error loading the trx file”. I have redownloaded the same file, and also tried the v1.0 and v1.1 files several times, all give the same error. The trexjrv1_2.trx I have is 157KB (160,870 bytes) although the manual says it should be 161KB.

To make things worse, on searching the forum here, I find that the paragraph in the PDF manual …

… is out of date, and it probably had v1.2 on it already before it erased it … ouch.

Could I suggest that the Configurator be updated to check it can read the new firmware file before it erases the flash?

I have tried using both the Configurator and TeraTerm to reflash the firmware without success. I know the serial connection is OK as it was working prior to attempting flashing.

Powering up normally I now just get the blue power LED, not the 5 flashes from the red LED. When connected to the board using TeraTerm I get any character I send echoed back. In bootloader mode, I get the character followed by a ‘?’.

- Thanks,

Problem solved, reflashed successfully using a different PC. It seems the Configurator possibly doesn’t like reading the firmware file under Windows XP?