TReX DMC Strange response to 0x81

I have taken over a project that is using TReX DMC01. The board is already wired but according to the previous developer was not working all the time. I was trying to test is so the very first thing I did is to issue basic commands to it. When I send 0x81, using Pololu Serial Transmiter, I get this:

09:56:11 AM sent 81
received:  00 '

I understand that I should get something like this 54 'T' 52 'R' 65 'e' 58 'X' 4A 'J' 72 'r' 31 '1' 2E '.' 32 '2'. If I send commands like 0xC0 or 0xC1 with parameters the motor is actuated the way it should, so that part is working. My question is whether, judging by the response I get, I can narrow down the problem.
Thank you!!


What are you using to send serial commands from your computer to the TReX and how is it connected to the TReX? What happens if you try different commands, such as 0x82 (get mode)? What happens if you try to connect to the TReX using the TReX Configurator program?

- Ben

I am using Pololu Serial Transmitter to connect to the COM port. I tried using TRex Configurator and it keeps saying “Could not detect a TRex motor controller on port COM#” even though Serial Transmitter connects to that port without any problems. I tired 0x82 and it gives me the same result as 0x81

02:24:38 PM sent 81
received:  00 '
02:27:58 PM sent 82
received:  00 '

I ideas where the problem might be?

So you are connecting the TReX to your computer’s serial port via a DB9 cable? How is this connected to the TReX? Can you try a different connection, such as a USB-to-serial adapter, or even a different computer? That the computer is getting a response at all from the device tells me that the TReX’s transmit line is doing something.

- Ben

Tried with USB-to-serial and different computer. I get the same exact effect

You keep not answering my question about how you are connecting things to your TReX and what you are using (specifically).

Can you see if you can talk to the bootloader? Follow the eight “Updating Firmware” steps on this page of the user’s guide to get into bootloader mode, but don’t use the TReX Configurator program. Instead, use a terminal program such as hyperterm or tera term pro at 115.2 kbps and see if you get any response when you send data. If you’re using RS-232, you’ll get an echo of every character you send (this doesn’t happen if you use TTL serial). If you send a random character, you should see the character ‘?’ returned. If you type the sequence ‘l’, ‘o’, ‘a’, ‘d’ you should see ‘L’, ‘O’, ‘A’, ‘D’ sent back. Do you get any non-zero serial bytes transmitted from the TReX’s bootloader?

- Ben

Thanks for the help. You gave me the right idea. I did not install the driver for USB-to-serial so whatever was sent, was essentially garbage.