Servo not reacting to slider in control center

Hi guys

I have a werird problem.

I have a 6 channnel maestro which worked perfectly. Easy setup and installation no problems there.
At first installation the servo reacted to the slider and it worked for weeks. After a week doing nothig with the servo and maestro i fired it up and then nothing.

So my tought was i blew it up :blush: . In short a bought another one, after plugging it in it was reconized.Hooked up a servo and again nothing. I have crossed checked my 5v external power supply but that is ok.

I am running on win 7 64 bit

Any suggestions would be apriciated.


double post :mrgreen:


What power supply are you using to power your servo? If you are using batteries to power the servo, can you try new or freshly charged batteries to see if that fixes the problem? If not, can you post your Maestro settings file here? (You can save your maestro settings file by selecting the “Save settings file…” option within the “File” drop-down menu of the Maestro Control Center.) Also, can you verify that your servo works by trying to move it using an RC transmitter/receiver or a microcontroller like the Arduino?

- Amanda

Hi AmandaS

I have tested my servo’s using arduino example servo sketch, gues what nothing.
Orderd new servo’s gues what, everything is fully functional.
I dont know how this happend but something must have been going wrong.

Thx for the reply and i love this pololu maestro diffently going to check out the other stuff you offer.

It is unfortunate your original servos were faulty. I am glad that your setup is working now with the new servos; thank you for letting us know what the problem was.

- Amanda