Servo moving out of control


Recently I ordered 1 Micro SSC with 2 GWS Mini servo’s.
After connecting the controller everything seems fine according to the leds.

First the yellow led will light up.
After the first command only the green led will flash when sending.
This seems fine.

But when I connect a servo to channel 7 and I send a command, the servo will start moving back and forth (oscillating) out of control.

I have tried:

  • separate power supplies for logic and motors
  • lowering the motor supply voltage
  • Changing the speed setting to 127 (and about everything in between)

What am I doing wrong? It’s my first encounter with servo’s so I’m guessing it’s my own fault … :frowning:



What are your power supplies? Do you get the same behavior with both servos?

- Jan

Thanks for youre reply!!

My power supplies are:

  • 5 volts for the controller: Regulated power supply
  • 4,8-6 Volts for the servo’s: This is also a regulated power supply with current limmitter display

The behavior is the same in both servo’s and choosing a different channel of the controller also makes no difference. As soon as the channel is activated the servo starts moving out of control.

I looked at the signals from the controller using a oscilloscope. When no servo’s are connected, the pulses look fine. When I connect a servo, the pulses are malformed and allot of noise is added.

It looks like the servo’s are putting load and/or noise on the signal lines.
How can I avoid this?


I suspect that the problem is with the power supply; can you try a battery pack for the servos? Regulated supplies often aren’t up to the task of delivering power to motors.

- Jan

Hello Jan,

That’s going to be a problem. I do not have a battery pack. I’ll try to build one in the next days.
The power supply I use can supply 3 amp’s continuously and 5 amp’s peak.

Is there no other solution to this problem?


There definitely are power supplies that are up to the task; the battery pack can be temporary to figure out if the power supply is the problem.

- Jan

Hey Jan,

Finally I got round to trying your suggestion. Guess what. It worked :smiley:
I’ve got 6 (older) penlite cell’s in a holder en connected it to the servo. Everything went perfectly.

Thanks for youre help :wink:

Kind regards,