Servo error when unplugged from usb

I have used more then a handful of these servo controllers and I’ve not seen this behavior before.
I’ve noticed when I connect the USB from the computer to the maestro it never does it, but when I disconnect it, sometimes the board flashes red and the servo loses power and does that whole “wind down noise”

I’ve tried 4 fully charged AA alkaline batteries (1.5v) and 4 fully charged rechargeable AA batteries (1.2v) the servo is rated for 6v, this is a new servo I’m trying, and the 1501 i normally use (from pololu) does not have that problem, I’m trying to pinpoint what the problem could be but since it never does it while the usb is plugged in I cant see an error message.

So my 2 questions are

  1. how do i retain the error logs while its not plugged in?
  2. Any ideas on what would be causing this?


If the Maestro loses power, you will not be able to read the error code after it restarts. If it does not power down, you should be able to reconnect the USB and read the error code in the Maestro Control Center. It sounds like you have some kind of power issue. Since the Maestro seems fine with the 1501 servo but not the new one, I suspect that the new servo draws more current than the 1501. Is the 1501 servo you mentioned a Power HD High-Torque Servo 1501MG? What is the new servo? Can you post a link to its specifications? Also, can you post some pictures of your setup including all connections?


I actually figured it out fiddling with it last night, I was racking my brain as to why it never errored out while the usb was plugged in. I looked up the “how to power a maestro” on here, and saw that you can power the processor and the servos separately, or together (by running a wire from the power to the vin). I hooked up a second power supply to just the grnd and vin and it worked fine.

So I guess to sum it all up, the processor was erroring out because I only had power running to the vin via a jumper. Once I connected the negative to grnd it stopped erroring out.

The tricky thing is, I had 2 power supplies, 1 was 4 AA alkaline, the other was 4 rechargeable. I hooked up the alkaline and even with the above fix, it still errored out. But with the rechargeable ones it did not. I spliced jumpers off a servo extention cable to go to the vin/grd - so the rechargeable ones must have a higher mAH output then the regular alkalines and they’re able to sustain the processor and servos.

I am glad you got it working; thank you for letting us know what the problem was. In general, you can get a higher discharge rate from a NiMH battery than from an alkaline battery. Additionally, you should be aware that discharging at higher amperages causes the battery’s voltage to drop significantly. This voltage drop is typically worse in alkalines than NiMH. Which is probably why it works with the rechargable ones. You can learn more about the performance of various battery types when discharging on this web page.