Servo controller maestro 12 one ch works

new to the robot thing. building rubic cube robot with grandson." problem1" enable channel 1 it works , enable ch 3 dont work retry ch1 it dont work. disable ch 3 and ch1 works. also the only ch that works is ch1, all other ch do not. i switch all servo to ch 1 and they work. “problem 2” i have ds3218 servos that rotate 360 and all they do is small movement with no rhyme or reason when slider is move. try different usb cables no help. one thing is I’m uaeing a 5.0 vdc 2.amp wall wart. wondering id it is supplying enough


You mentioned in an email that you accidentally clicked the firmware update button, and the Maestro became unresponsive after that. As a first step, please go through the full firmware process using the latest firmware in case the existing firmware got corrupted by the accidental update. You can find the instructions on how to Upgrade Firmware here

Please let me know if you still have trouble after doing that.


dan. thanks for your help. hard booted and install 1.03 firmware it works. question: on the digtal servo it seem to be a little slush and when i slide the bar and go off the path servo hangs up and have to go back and find the last spot it was at, did that make sense? think my problem was the slide parts were to tight
and making to servo to overload,i would have to reset controller and it would start working, do you think that could happen?


It’s possible your problems are due to your mechanical elements being too tight. Have you tried adjusting those parts to make sure they move as freely as possible, and that the servos are not moving outside of their range? If you have tried that and are still having your servos hang up, could you record a video and post it so we can see if we can help determine what is happening? Also, can you tell me how you are powering everything?



First off I want to thank you for your help, means a lot!. Yes, some of the parts were tight. Worked on that last night.

The ds3218 servos seen to be touchy thru maestro control center, seen to lose where it was at when I move the slider bar. not to sure if I have setting right yet.

I have a 5.0vdc wall transformer 2 amp.

Thanks again

Bill Cummings

It is good to hear that you were able to get everything moving more easily! What you are describing sounds like a power issue. I looked up your servo, and it seems like each one could be drawing bursts of current up to around 1.5 A, which might be too much for your power supply if you have multiple units straining simultaneously. If you continue to have issues, I suggest you try a more powerful supply. For example, we carry a 5V wall power adapter that delivers 5A that might work better for you (I would also recommend picking up a DC Barrel Jack to go with it so you do not have to cut the connector off the adapter cable).


dan, the new power supply fix the servo movement problem.
thanks again for your help. we will building more stuff and your site will be the first we visit
thanks again