Serial servo controller - No lights

I just recieved an 8-servo controller with a standard sized servo. I’ve got a 6 volt battery pack attached to the VIN/GND pins on the board. My OS is Fedora core 5 and I’m using the sample tk program posted on the website.

I attach the battery pack to the serial controller and the yellow LED comes on solid.

I plug in my serial cable and the light goes out. I start the sample program and still no lights. Tried setserial to set the baud rate and still no lights. Also tried minicom and wrote a python program with no luck. Tried another cable and computer with same results.

The serial cable is RS-232C DB9 with matching pins on each side (no crosses). Male on one side and female on the other.

I also tried in SSC II mode with a program on freshmeat I found called sam. Same results.

I read the docs and they don’t indicate what’s wrong when there are no lights after plugging in serial cable.

Why would I lose all lights when I plug in the serial cable?


You probably have the shorting block connecting the reset line to one of the serial port handshaking lines. You can either remove the shorting block (and lose computer control of reset) or toggle the output to which your reset line is connected.

- Jan

Well I screwed up. I was trying different combinations of jumpers and pulling the power on and off. I wasn’t paying enough attention and applied the servo power reversed. I got a nice big pop followed by a bad smell. I took apart the servo and sure enough, a big burn mark across the board. So I guess my project is on hold for now. I’ll order a new servo and controller Tuesday and make sure to not make such an expensive mistake again!

I took off all the jumpers from the servo controller just before that and had some success with my python program (green flickering light). But just as I was trying to connect the servo and power, well… that happened.

I’m sorry to hear about your servo. Are you sure the servo controller needs to be replaced, too? The servo power shouldn’t affect it, and you can actually do some initial connectivity testing without connecting or powering any servos.

- Jan