Qik 2s12v10 Reverse Problem

I have the qik 2s12v10 that I am using with my RC tank. Every time I reverse or drastically change the throttle I get a motor error “Motor 0 Fault”, “Motor 1 Fault” or both. I disabled all “Shut Down Motors on Errors” so I don’t see why I still get this. Any ideas?


Do the motors actually shut down when the fault occurs, or does it just report the error and keep running?

- Ben

It reports the error and the motors stop. I have to cycle the power to get the motors running again.

Can you give me more details on exactly what’s happening? For example, when the motors shut down, I assume you see the red error LED turn on and stay on? What is the green LED doing (i.e. even pulsing or intermittent, brief flashes)? What happens if you try to issue another motor command at this point? What happens if you send a non-motor command, such as the one to read the error status?

I can imagine several potential causes for what you’re seeing, so knowing more will help me narrow down the possibilities.

While I want to get to the bottom of the problem in case it is the result of a firmware error, it sounds like the ideal fix would be to enable the acceleration (and possibly brake duration) parameters. Your motors are overtaxing the motor driver to the point of fault when they near or exceed their stall currents; acceleration will ramp up the power to them more gradually, keeping the current draw lower as they increase speed. Brake duration brakes the motor for a specifiable period of time when you command it to change directions, which can also dramatically decrease current spikes associated with direction changes.

- Ben

Yes, the red error LED turns on and stay on. The green LED blinks every 1.5 seconds, which is expected because I send data to it pretty often. If I issue another motor command nothing happens (besides the green LED blinking). I can send a command to it to read the error command, which is either a 1 on bit 0, 1 or both.

I have taken your suggestion and set the brake to 0x32 (.5 seconds) and acceleration to 0x4D (~ 2 seconds). I also set the current limit to 0x18 (about 7.2 amps). However, it still does what I described above.

I send a speed command for each motor every 1/4 of a second. When I am controlling the motors they don’t seem to accelerate, they seem to go full speed right away. However, when switching directions it does appear to brake. I have verified that the acceleration parameter is set by using the get acceleration parameter. Plus, the motor controller returns 0 when I set the parameter.

Thanks for you help.

Can you tell me about the motors you’re using (what is their stall current?) and how you’re powering everything?

An acceleration of 0x4D is pretty high (what do you mean by ~2 seconds?). With this acceleration, the motor speed will go from 0 to 127 in around 70 ms. What happens if you try a much lower acceleration, such as 10, which means it takes around 0.5 seconds to go from 0 to 127? Does the acceleration become noticeable? Does it prevent the motor fault error?

- Ben

I don’t know what the stall currents are for the motor. They are motors that came with the RC tank I bought. All I can tell you is they use about 5 amps full speed. I am powering the motor controller and microcontroller off a 7.2V 2000mAh 6-cell NiMH Battery made for RC cars. I am not using the 5V output from the motor controller to power anything on my tank.

I misread the manual in regards to the acceleration parameter. I have set the values given your suggestions, and the acceleration difference is noticable. This reduces the problem significantly. The only time I get the error now is if I run my tank into an immovable object, or my tracks get grass in them. Is the only way to completely stop the problem to monitor the error pin and reset the motor controller if the error happens?

Thanks for all your help.

If setting the current limit, current limit response, and acceleration parameters aren’t enough to prevent the motor fault, then yes, it sounds like you will need to monitor the error pin and reset the controller. I’m not sure why it’s not automatically recovering; this is something I will need to look into. In general, it sounds like you potentially need a more powerful motor controller for your motors, though I’m glad to hear the qik works if you sufficiently limit acceleration and avoid conditions that stall the motors.

- Ben


I’ve looked into the matter further and identified a bug in the firmware that was keeping the qik 2s10v12 from dealing with motor driver faults as intended. Unfortunately, the qik does not have upgradeable firmware, but if you haven’t found an acceptable workaround, you can send it back to us, and we’ll replace the firmware with version 2, which fixes the motor fault bug.

- Ben

That would be awsome! I didn’t really want to use another 2 pins to monitor errors. How do I go about sending it back?

Please mail the unit to our address as written on our contact page, and include a reference to this thread to help us identify it along with the address to which we should ship it back. If you purchased the controller directly from us and know the original salesorder number or the name of the person who ordered it, please include that as well.

- Ben