PWM control of rc servos

Hi Guys,

I want to use a SpringRC SR-403P robot servo. In the specification of the servo it says: “signal way: PWM”. Is it something different than controlling standard servos? Should I use channel 12 on the Mini Maestro 16 with the “PWM output” enabled and channel 12 set to “output” instead of any other channels? The servo spec attached.
SR40 series robot servo specification - 20111513562041759.pdf (926 KB)

Hello.

The datasheet talks about 0.5 - 2.5 ms pulses, so I think you servo responds to standard RC servo pulses. You should be able to connect it to any Maestro channel that is configured as a servo output; just make sure not to send pulses outside the range of 0.5 - 2.5 ms.

- Ben

I set the pulses 0.512-2.496 ms. When I turn the power on the servo moves just a little and stops and I got the errors “Advance update late (1 times)” and “Basic updat late (1 times)”, picture attached. When I move the slider in the Control Centre the servo doesn’t respond at all. This SpringRC servo is pretty much the same as Hitec’s HSR-5498SG.
hitec-hsr-5498sg-digital-servo-specsheet.pdf (180 KB)


Hello, Jaduma.

Thank you for the picture.

Please reset the Maestro to its default settings (from the Device menu), then change the Serial mode to “UART, fixed baud rate” (it doesn’t matter what the baud rate is because we’re just trying to control the Maestro over USB), and then click Apply Settings. With these settings, it should be possible to control the servo by moving the appropriate slider in the Status tab, even if we don’t get the full range of motion.

How are you powering the Maestro and the servo and how is everything connected? Posting a photograph of your setup might help. The Maestro can be powered from USB for now, so please don’t connect anything to the Maestro’s VIN line and leave the VSRV=VIN jumper detached.

It is normal for servos to twitch a little when you first apply power to them.

I would not worry about the performance flags for now.

–David

I tried that David and it still doesn’t work. Any other servos work fine so I think there might be a problem with those particular servos. I requested info from the manufacturer and I am waiting for their response. Anyone out there who used those ServoRC SR-403P servos?

It could also be a problem with your power supply (maybe your SR-403P servos draw more power than your other servos). As David asked in his previous post:

- Ben