Problems with serial communication mini maestro


i have an maestro mini 12-channel servo controller.
I’m using a usb cable for connection to the controller. i plugged in the servo power lines to the 5V from my pc power supply. the servo voltage should be in the range of 4.8V to 6V.
(i tried 2 servos: “robbe futaba s3003” and “Servo SES 750 2BB”)

i installed the drivers. (i have win7 64bit)

The “Maestro Control Center” recognizes the controller, and the controller is in the detect baud rate mode.
everything is fine until here.

but when i tried to pluggin a servo and enable it (after switching the detect baud rate mode off), to test if it is working, nothing is happening. i tried every mode in the serial settings.
the controller led is green and the yellow led gives only one flash.
i get the error code 0x00000

what is wrong?

I have nearly the same problem as discussed in this thread

but i have no double blink from the yellow LED, just a single blink… and my power supply should have enough power for the servos.


Did you make sure to apply settings after switching detect baud rate off? The Control Center offers to do this for you, but if you canceled that dialog box it will not prompt you again.

Can you describe what you see on the interface (green or blue circles?) when you enable the servo? Also, you said it was doing a single blink - is it on about 50% of the time or on only very briefly?


Yes, i applied the settings after switching the serial mode. And the single blink is very short. so i’m no more in the detect serial mode, where the led blink is longer.
When im enabling the servo, there is a trackbar an when i’m moving this trackbar i see green an blue circles, but my servo is not moving.
Are the servos of the correct type?

Hm, i think one of my servos is defect, because now one is working.
i installed the drivers new.

thanks for your fast reply.


Okay, I am happy to know that it seems to be working. Please let us know if you have any more trouble!