Problem with older 8 port servo controller

I have the older 8 servo controller with the dip package PIC. I assembled the kit around a year ago and put it away to work on other things.

When I got it back out and started tinkering, it passed the initial test (all LEDs on with serial line grounded). So far so good.

During my next tinkering session, I accidently hooked the 12v side of my power supply to CON1 and fried the poor thing.

So I’ve put in a replacement PIC and it passes the initial test with 5v on CON1. I get a solid yellow LED when I connect CON3 to a serial port.

I’ve tried sending commands with the Visual Show demo program in Mini SCC II mode, Pololu mode with the VB test program I found in this forum, and a VB.NET program I wrote in Mini SCC II mode.

In all 3 examples, the red LED comes on solid and the green LED flashes indicating too high of baud rate. I’ve tried everything from 1200 to 19200. I’ve tried COM1 and COM2 with the same results. With my VB.NET program, it happens after the first 0xFF byte is sent.

Could I have fried more than just the PIC with 12v? I don’t have access to an oscilliscope (or know what to do with one, for that matter) I do have a basic multimeter if that helps.



There’s not much to fry on the board besides the PIC, and it seems to be doing something, and even responding to the serial input, so that’s a good sign. Is there a reason you’re using the CON1 connection? What happens when you apply a higher voltage to CON2 (to the voltage regulator on the servo controller board)?

- Jan

I tried that too… I’m using a power supply from an old external CD-ROM, so I tried putting the 5v on CON1 and the 12v on CON2 and it did the exact same thing.

I should also mention that the serial cable I’m using is an old kernel debugging cable that’s female on both ends. So I bought a 9 pin gender changer to attach the controller. Could this have anything to do with it? I assumed the pinouts were the same, but since the cable was 2nd hand, I can’t be sure it works for this application.

Actually, I’m really suspicious of this cable now, because I think it’s technically just a null modem cable. And if memory serves, the pinouts are swapped.