Problem with Mini Maestro 12 and MG90S Servo

Hey guys,
I’ve got the following problem, which makes me go crazy since 5 days:
The controller I ordered is the Mini Maestro 12-Channel Servo Controller.
I connected several Tower Pro MG90S Servos to it and enabled them inside the Maestro Control Center. On first try it said: “The servo controller is currently configured to detect serial baud rate. Until it has detected the baud rate, it will not be able to control servos. Do you want to change the serial mode to UART, 9600 baud and apply all settings now?”

I applied them, enabled the channels but the servos don’t seem to correspond to the slider movement. There is no movement or even a strange sound. Since I am a complete beginner with this kind of stuff I have no idea what I should look for.

I watched a YouTube Video in which a guy didn’t have to apply any other settings than the standard ones. And in his case it worked without any problems. I also tried using another Servo, the Tower Pro SG90, but the problem is the same.

What can I do to make it work?
Thanks for your time and answers!


I am sorry you are having trouble controlling your servos with the Maestro. We expect users to see that message; applying those settings is fine. Can you tell me how you are supplying power to your servos?


I just connected the controller via USB to my Computer. I was assuming that was enough.
I just followed a tutorial about a 3d printed robotic arm and there was a list of things I’d have to buy. There isn’t any further power supply listed.
Could that be the problem?

Ok this is really embarrassing. I just watched the official video to the maestro and I obviously need an additional power supply. I’m sorry for that dumb question but I am a complete beginner/noob when it comes to controllers and all the stuff around it.
I’ll just act as if it was a joke :smiley:

Anyway, thank you for your support!

I am glad the video was able to help you figure out what you needed. Thanks for letting us know!