Pololu 23201a..please help

HI I ordered this part along with other parts to fix my seagate HDD… I place the adapter on my breadboard, have tried multiple pc’s serial cables, etc. and i still cannot get the “loopback” test to work. I open hyperterminal and it will NOT show me typing anything at all… the TX and RX are connected using one male jumper wire. Can someone PLEASE help me i dont want to have to return this part as the dealer i bought it from was in canada and i am in Boston, MA. Thanks

and yes i have read this

seems to be a common problem? I have everything wired correctly…what else can I try?


This isn’t a common problem, but we have had several customers report problems with their adapters after following instructions on recovering bricked Seagate hard drives. We have added a note to the adapter product page with a warning and suggestions for avoiding damaging LC voltage spikes that can occur when powering the adapter with long leads. Does the board get hot when it’s powered? Are you able to get your loopback test to work using the serial port directly (i.e. without the adapter in the system)?

- Ben

Hi and thanks for the reply. I will have to test the serial port test, but three PC’s all which are fairly new I dont see how all three would have the same problem. And yes the jumpers are very short and the “chip” on the adapter does get warm.

I’m not necessarily thinking it’s a problem with your computer’s port. You could just have something wrong with your loopback procedure (e.g. connecting to the wrong COM port with hyperterm). If you get it working without the adapter, it means that other aspects of your test are correct and there is likely now a problem with the driver. Your jumper wires might be short, but you’re connecting them to somewhat long leads from your computer’s power supply, right? Can you estimate the total length of wire from your power supply to the adapter?

Do these three computers you’re using have serial ports (I only wonder because you say they’re fairly new, and computers these days don’t typically include serial ports), or are you using an additional adapter, such as a USB-to-RS232?

- Ben

Estimated length would be from power supply to the adapter (breadboard) 6-8"

Yes two of them had serial ports and one is an addon card serial port.

all using “com 1”

any other way to test if my serial port is actually working with com1?

You could try using another serial device, but the easiest way should just be to connect the serial port transmit line to the serial port receive line and then see if characters you transmit get received (i.e. a loopback test on the port by itself).

- Ben

Yes I just did this and I got the typing to appear in hyperterminal. So basically every single thing is working just fine except the adapter. How can i get a replacement? I really dont want to have to ship it back to canada. If I have to I will buy another one, but that is not fair and I would feel slighted if I had to do so. please suggest. thanks

One last thing: can you post a picture of your setup, showing how you have the adapter connected to everything? How long were your leads when you applied power for the first time?

- Ben

I can try to take a picture later on. Leads were always the same length.

Assuming I don’t see anything in your picture that would explain why things aren’t working, I can set you up with a discount on a replacement unit from us (you don’t need to return your unit to Canada).

- Ben

Thank you very much I will be going home from work soon and will post it asap for you. Thanks alot


sorry just my phone pics

and yes its missing the loopback jumper but its the same type of wire.

I can’t be completely sure from your picture because the wires get clipped by the right side of the picture, but your description of 6-8" leads seems to be inaccurate. You seem to be using 6" jumper wires connected to power supply leads that appear to be much longer then 2". Were you counting the length of the power supply wires in your estimate of the total lead length?

And just to cover all the bases, did you ever independently verify (e.g. by using a multimeter) that the voltage you’re supplying to the VCC is +5V relative to GND and not 12V or a negative voltage rail?

- Ben

I took the pictures in a hurry as i had something to get finished but ok so the wire total is prob 6" jumper 3" from PS. still not going to effect getting power and no i dont have a voltmeter for that application. but again i never connected it to the yellow wire. I work in the IT dept and I am very familair with the diffrence between 12v yellow and 3-5v Red

The problem isn’t that the lead length prevents the board from getting power, it’s that the inductance in the long wires causes an LC voltage spike every time you plug the power wire into the breadboard, which most likely briefly pushes the voltage on VCC well above the chip’s 5.5 V maximum. Using a cleaner power supply, such as a battery, and shorter wires (an inch or two) can greatly decrease the magnitude of such spikes, but the best way to protect the board is to put a high-ESR (e.g. electrolytic) capacitor across VCC and ground in your breadboard close to the adapter.

Please contact me directly at ben at pololu dot com for instructions on getting a discounted replacement unit.

- Ben

I just dont get it…I got the new one installed everything including the capacitor and I STILL cannot get the hyperterminal to “talk” to itself

I’m sorry to hear it’s still not working. That really makes it sound like there is something wrong with your setup. The two things that immediately come to mind are:

  1. Are you sure you’re not using a null modem cable to connect to the board?
  2. Are you sure you’re supplying the board with the voltage you think you are? Your going off of wire color alone does not fill me with confidence. For projects like this, I think a multimeter would be well worth the $15 investment.

- Ben

The cable I bought at Radio Shack. I did the test with “loopback” on pins 2-3 and it worked fine. so I am assuming I have the right cable.

I have no choice then, I have to go get a Multimeter. Thanks I will update soon