Orangutan SVP-1284 not working

So i just got an Orangutan SVP-1284 and it doesnt seem to work, so i connected a 9V battery to it, removed the screen, and i get this:

So on my windows 7 64bit machine i installed the driver, listed here: pololu.com/docs/0J39/5.a and connected my board… i got an error message stating that the board is not working correctly, because windows could not recognize it, so i went here: USB-to-Serial adapter signed driver for Windows 7/Vista installed the driver from the manufacture and it installed but now says that the device can not start.

Went to my MacBook Pro, installed the mac drivers. Also, I followed the steps here for fixing the Pololu.kext: USB orangutang Drivers not installing on MAC but when i run ls /dev/tty.* the orangutan is not there…

Went to my Win 7 32bit machine and same as the 64 bit…

Is this a defective unit??

edit: replaced the battery and i dont get the beep now

connected the screen and i get the demo program, so i think is a driver issue, i cant connect it to my system

The red LED in that youtube video is blinking in an unusual pattern, and that clicking sound is not expected. Your 9V battery was probably too drained to power the SVP properly, and so the SVP was resetting every couple seconds. I’m glad you were able to fix that problem.

The drivers you found from USB orangutang Drivers not installing on MAC have nothing to do with the Orangutan SVP. They are for other products we have based on the CP2102 chip. All of the drivers for the Orangutan SVP are available in the Orangutan SVP User’s Guide:

Let’s focus on getting the SVP to work on one of your Windows computers because it probably won’t work on the Mac. Please plug in the SVP and post a screenshot of your Device Manager showing the entries that appear for the SVP when you plug it in. There should be three. Also, please try double clicking on them and tell me what the Device status box says.


installed drivers and got this: img716.imageshack.us/img716/2505/orangu.jpg

Could you please expand the Ports (COM & LPT) list? That’s where the SVP’s drivers should show up if they were installed correctly.


nah not there only Bluetooth com ports


i forced the driver using the one from that site you just posted and got this:

Found the problem… The cable you guys send with the unit doesnt work very well… tried another cable and worked :slight_smile:


I’m glad you got it working using the new USB cable!

And I’m sorry that you got a bad cable from us. You can email us directly if you would like a replacement.