New LV DSMC trouble

Loha all,
I simply get no response from my new bought low voltage dual serial motor controller. I connected a Tamiya (70168) double gearbox to the M0+ M0- and M1+ M1- resp. VCC, VMOT and ground are connected to 5.3v power supply. The GND and SERIN are connected to a RS232 port of my PC. When I power on the powersupply it does nothing at all. Although it’s not much to work with, can any one give my some tips or tricks to debug and/or fix this problem?

Edit: I’d really like to know what the minimum connections are to get a blinking LED or pulsing motor. I just like to get any alive signal.


You have to send the motor controller a serial command to see it do something.

The LEDs are in parallel with the motors, so they cannot indicate anything independently of the motors. Also, 5.3 V is a suspect voltage; how are you achieving that?

- Candice

I was kind of hoping the controller would give some indication at powerup. I have tried to send serial commands but that doesn’t seem to work either. However, that could be my fault since I write my own software (which worked perfectly for a USB and a LPT board but that aside). It makes it hard to debug if I am not 100% sure hardware wise everyhing is ok.
So just to get my facts straight; the controller does absolutely nothing when power is applied?
5.3 does sound suspect but it is what a fully charged 4 cell battery gives. I do however use a stabalized power supply with voltage controller.

Thanx again, any help is much apreciated.

I could just everybody waiting to see for me to see the light and acknowledge my dumness. Well it happend. Sending some commands that actually reach the board made all the difference.
Still unfortuned that there is no signal whatsoever on powerup. That kinda got me of track. Anywayz. Lots of fun now with my controller and baby bot (can only survive on string to PC yet)
Thanks for the one reply though.