Need help with qik2s12v10 Status LED

I bought 2 pieces of qik2s12v10 last week. Until yesterday, I have a problem with one of them.
Its heartbeat green LED stop blinking, in other word it doesn’t even on.
Actually i face this problem since last week, when it was delivered to my place.
But, sometimes it start blinking and work perfectly after several minutes in idle.
Manual says, if the LED stop blinking, it is whether over supply voltage or damage. I already measure my power supply and it shows accurately 12 V. Can you explain what happen to my Qik?

there is an attachment in demo mode

Hello Harris.

Do you have any motors connected to your qiks? If so, can you disconnect them and see if the behavior changes? Also, what are you using for your power supply?

- Ben

In the picture, I didn’t connect them with motor and both of them is in demo mode. I use 12V 3A power supply, its voltage is 12V accurately when I measure it.

Can you post a close-up (and non-blurry) picture of your solder joints? If your camera has a macro mode, please use that. Otherwise, make sure you hold the camera sufficiently far away from the board (and instead use its zoom feature) to allow things to be in focus.

In general, it sounds like the controller is working properly but you have a bad connection somewhere that is causing it to continually reset or rapidly enter and exit demo mode. Can you see if jiggling various connections makes any difference (e.g. does anything change if you apply some extra force to the demo mode shorting block)? Does the status LED do anything if you remove the demo mode jumper and cycle power to the board?

Also, has this malfunctioning controller ever worked properly for you (aside from the random times when it seems to briefly start working after sitting idle)? Can you describe all the connections you have to the controller?

- Ben

Sorry for delay to reply, I only use Tx Rx GND connection to connect with CP2102, VIN GND Input power supply 12V, and both motor connectors. The motor itself doesnt drain current more than 5A per motor.

I already tried connect both qik2s12v10 to laptop with fix 9600 baud rate. Only one qik2s12v10 that respond to command from Pololu serial transmitter software. The other one doesn’t respond, the green LED is stop blinking. Sometimes when I plug power input to the qik, the red LED which indicate reverse direction of motor 1 is on. It has the same problem when I only connect with power input even in demo mode. I already tried to remove fix baud rate jumper and demo mode jumper or even add extra force to jumper when controller is on. Until now, that controller never worked properly and has the same condition as I describe above.

If you think it has a bad connection, where it should be?
I attach a picture using macro function and it still a little blur.

Hello, Harris. Ben has asked me to help you with this problem.

It seems like the board is getting power. This mostly rules out a problem with your GND and VIN connections. However the green status LED is not blinking and the microcontroller is failing to execute demo mode, so it seems like something is wrong with the microcontroller or its power source. Do you have a multimeter or an oscilloscope so we can probe voltages at various points on the board to see what is going on?


hallo David,

so after i measured with multimeter this is what i got:

after reset and no jumper condition :

M0 : 117.4 mV
M1: 0.00 mV
Vin-Gnd: 11.98 V

i used 12 V as my voltage source.

in my point of view, there is a problem with microcontroller inside qik because both M0&M1 should be 0.00mV in that condition. So, is it necessary to exchange my Qik? because i need it quick…