My Mini Maestro is ignoring commands

I’ve got a Maestro 12 that I’ve successfully used before but which isn’t working for me now and I’ve found no solution after far far too many hours of messing with what I previously thought of a “convenient” device. I considered that the hardware might be damaged, but my Maestro 6 gives the exact same results. Here are the facts:

  • There is proper 5V power available supplied and the VSRV=VIN jumper is set.
  • The USB drivers recognize the Maestro when it’s plugged in and both of its comm ports show up.
  • I’ve set the serial mode to UART, fixed baud rate (9600).
  • I can use Maestro Control Center to drag my servos around manually just fine.

So far so good – the hardware (both Maestro and servos) works, but software is another story. All applications I’ve tried so far can open the command port without error, including the app I’m working on, two other binary terminal apps, and of course the Pololu Serial Transmitter… but none of those apps seem to have any effect on the Maestro when I send properly-formed commands other than causing its green light to blink off for a brief moment.

What bothers me most is that I’m using code I used with this same Maestro on another project (hence I know it worked before) and in fact my old app doesn’t even work any more… so I have to suspect something’s gone wrong somewhere else in the settings or OS…? except that it doesn’t work on my laptop either (and used to).

Anyone have any ideas? I’ll have to dig up my BASIC Stamp if I can’t get this Maestro working, which would be a shame.


I suspect something changed in your Maestro’s settings. Can you try using the Maestro Control Center to save a settings file (File->Save settings file…") and post it here? After you save the file, you could also try resetting to the default settings (Device->Reset to default settings…) because you can always restore from the settings file you saved.

- Ryan

Hello, flaXen,

If you want to send commands to the Maestro on the command port, then its serial mode should be set to either “USB Dual Port” or “USB Chained”. (The UART modes cause the Maestro to only respond to commands on its RX pin.)

For a detailed explanation of how the different serial modes work, you can refer to section 5.a of the Maestro user’s guide.

- Kevin

Thanks guys, it was just a matter of setting it to the correct serial mode. I read the serial section in the documentation but the fact it says commands will be ignored didn’t register with my brain because I expected it to need to be in UART mode. I think it’d be helpful to clarify that part of the documentation a bit, but this problem raises another question for me: Is it possible to programatically set the serial mode to prevent this from being an issue in the future?

I’m glad that solved the problem for you. Unfortunately, the Maestro does not support a serial command for changing the serial mode. This is to prevent a bad serial command or noise on the serial lines from inadvertently changing the serial mode to the wrong option.

It is possible to change the serial mode through the native USB interface (which is what the control center software uses), but if you were to think about doing that, you might as well just consider using native USB commands for servo control as well.

- Kevin