Mini Maestro 12 stopped working

Hi, my Mini Maestro 12 just stopped working after operating for a few months. When I disconnect the USB cable from the device, the yellow light flashes then the green light comes on, goes off, yellow and green light come on, then they both go off, then nothing. It is not showing up in the Maestro Control Center or as a USB device. I tried a new cable and a different USB jack, same results. Power is getting to the servos, when I disconnect and reconnect power I can hear the servos twitching. Is a new servo controller in my future?


I am sorry you are having trouble with your Maestro. Do you know if anything happened between when the Maestro was last working and when it stopped working? Can you double check that the USB ports and cables you are using work with other devices? Do you get a sound when you plug the Maestro in, or does the Maestro show up at all in your device manager (it might show up as an unknown device)?


I am using more than one servo controller on my project and the servos that are being controlled by this one I haven’t been using, so nothing has changed with this controller. I only happened to notice the problem because it was no longer listed in the Device Manager. I don’t remember if I heard any sounds when I unplug and plug in the device but I believe there wasn’t any but I will double check. As far as the USB ports, I tried plugging it into different ports with the same result.

Can’t tell about the sound when I unplug it because my sound isn’t working to well but it is coming up as an unknown device.

It sounds like your Maestro might be damaged. This could have happened with something like a static shock. Although it seems less likely, it might also be that the USB connector pins are bent; if you post pictures that show the inside of the connector, I could take a look. Also, if you email us, I might be able to help you out with a discount on a replacement unit.