Micro Servo Controller & Bluetooth

So I am hoping that someone here can help me shed some light on how to get the micro controller going. I recently purchased the BlueSMiRF bluetooth connector from Sparkfun.
sparkfun.com/commerce/produc … cts_id=158
I’am trying to get it working in conjunction with the micro serial servo controller.

The BlueSMiRF supports 0-5v Logic level so I figured it wouldn’t be an issue to get it hooked up since that is also what the servo controller’s doc say it supports.
I have 5volts fed into the system, and when I hook it up on the logic level serial inputs / outputs I get the yellow light by itself. When I connect to the bluetooth device and write 3 bytes (using the MiniSSC II mode just for testing purposes) [255,0,0] I get an echo back from the connection repeating the bytes I wrote. The servo doesn’t move. I apply power on the two terminals in the upper right for the servo’s (5v), write the commands, and I get a yellow light + a red flashing light.

Any help would be greatly appreciated.



When you get the echo back, does the yellow light go out? That part of what you describe sounds good.

The red flashing light is a bad serial data error, but I suspect you might have a power problem. Is the 5V source you are connecting to the servos the same source as for the board? What happens if you apply power for the servos with a separate battery pack?

- Jan

No, the yellow light doesn’t go out. I have been playing with it a bit more and am able to get data back from the controller now.

So, when I have the micro controller fed by a 9v battery, and my bluetooth module off of a different 5v supply I am able to read and write to the controller (with no servo attached). It no longer blinks green on transmit either.

Currently, when I connect it spits out “CONNECT,00081B879D2D”. After I write [255,1,254] it will respond with those bytes, and then “ONNECT,00081B879D2D” again.

Now, if I attach a servo, and a 5volt supply to the servo power pins it will blink red as soon as I connect to it. It spits out one charachter (255).

Thank you sooooo much for any help :slight_smile: I’m waiting for a ttl converter to show up in the mail (hopefully tomorrow) or am going to hack up a DB9 cable to play with it directly I think.


Could you be more careful in your descriptions? For instance, “it no longer blinks green on transmit either” is confusing since this is the first I see about a green LED, plus I’m not even sure which device you are talking about.

In general, connecting servos or the servo supply should make no difference to how the rest of the servo controller behaves. The servo power powers only the servos, and the only connection from the servo controller to the servos is a one-way control line (i.e. servo controller output). The servo controller echoes back bytes on its serial output, is that the echo you are talking about?

Also, it would really help if you could look at the serial line(s) on an oscilloscope. Do you have access to one?

- Jan

Sorry if my descriptions of the situation are poor :slight_smile: Let me take another swing:

Here is the situation I am currently in:
I am using the Micro Serial Servo Controller

I have a 9 volt battery hooked up to the VIN / GND in the lower left of the board.
I have Logic Level TX/RX hooked up to the bluetooth module.
I have 5 volt feed hooked up to the bluetooth module.

When i fire everything up, the chip comes up with a yellow light, and stays on. When reading / writting to it, it echos the text above and generally seems very happy.

However when I connect a servo to the chip, and feed a 5volt current to the Servo power pins the second I open the connection, the yellow light stays on, but it starts flashing red.

Unfortunately I do not have an oscilloscope. I have been a programmer, and am playing with robotics as a hobby at the moment with an eye on going back to school for EE.

Sorry for causing any hassle. Thanks,

Well, that does sound strange. Just to be clear, the two 5V supplies are independent, right? Have you tried different servos and different servo ports?

As I said before, connecting the servo shouldn’t affect the operation of the servo controller; the common exception is when there is a power issue. As the servo begins moving, it draws more current from the supply, which could dip and cause other electronics using the same supply to operate erratically. 5V is usually a suspect voltage for a servo supply since it means it’s getting regulated. Are you sure your regulator can handle the load a servo presents?

It would also help to know when exactly the error occurs. Your earlier post makes it seem like the second character causes the problem, but your latest post indicates an immediate failure. Can you send the three bytes separately so that you can tell when the error occurs?

- Jan

Solved the issue. Turns out that the bluetooth module was echoing data to the pololu when the connection was initialized. I set it to silent mode and everything works like a champ.

Thanks and sorry for the hassle :slight_smile: