Micro Maestro - No Pulses

I have connected my micro maestro to a linux PC.

I am using the UscCmd program to communicate with the micro maestro and am unable to get any servo pulses out.
I have plugged both an electronic speed controller in and also tested the servo signal line with my oscilloscope.

I have tried:
UscCmd --servo 0,4000
and then
UscCmd --status
and it tells me that the target is set to 4000 and that the position is 4000
and no pulses…
I have also tried 5000 6000 and 8000 but I can’t seem to get any signal out of it.

Is there some enable message that I have missed?
I have the green light on and the orange one is blinking slowly.

(I am in a command terminal with no window system so I can’t use the Control Centre application)


Hello, Pete.

You will need to change the Maestro’s serial mode from its default (UART, detect baud rate) to something else before it can actually send pulses controlled by USB. This can be done with usccmd by editing a Maestro settings file, but it is easier to do from the Maestro Control Center. Do you have access to a Windows computer or a Linux computer with X?



I took a stab in the dark and guessed that the field in the config file should be “USB_DUAL_PORT” as I couldn’t find these field codes listed in the manual, they were referenced as “USB Dual Port” and similar.

All working now.