Micro Maestro, green LED blinks fast, yellow slow, no servo

Sorry for the telegram like title.

I just received my Micro Maestro board on the mail, I installed the controller program, plugged the board, went through the new device detection steps and then connected a servo and a 4 NiMg pack to the servo power pins. So far so good but I can’t get the servos to move. All the board does is blink the green LED about 5 times per second and the yellow LED makes a double blink every second or so.
I tried both USB Dual Port and Daisy Chain serial settings and still the same, on the top right of the Pololu Maestro controller window I have an “Error Code: 0x0000”

Any ideas what may be my problem?


What are you doing that would cause the servo to move? The yellow double-blink indicates that you have activated at least one channel - are you sure it was the same one that you connected your servo to? Serial settings are not necessary for initially testing the control center with the Maestro, except that you should not be in an auto-baud-detect mode (the double-blink indicates that you are not, and the Control Center will warn you if you are.)

Without having any more information about your setup, I would guess that your batteries are simply not charged. Can you verify that they are charged and that the servo and batteries work fine with a different controller, like an R/C receiver? Do the servos twitch at all when you apply power?


Ehh… yep, low batteries.

Now if you’ll excuse me I’ll hang my head in shame in the corner for a while.

I am glad the problem was that easy to solve, anyway. Good luck with everything else!