Micro Maestro gone?

I’ve just had a problem with my Micro Maestro Servo Controller. When I connect my PC to it the computer doesn’t detect it. The green led on the Micro Maestro doesn’t lit either. It seems like the memory on the Controller is gone, perhaps due to an accidental polarity inversion on the VIN and Ground ports, i don’t know.

Is there a way to recover the Micro Maestro?

Thank you.


There is one more thing that we can try, but before that, can you verify that you have removed everything connected to your Micro Maestro and tried plugging it in only to USB? Please also try a different USB port and USB cable if possible. Do any LEDs ever light up on the board?


I have ued the usb cable and PC port with other device and it works fine. On the Micro Maestro the yellow led blinks once when the USB on the board is just plugged. Very funny, if you leave the usb on the board just plugged halfway, the yellow led blinks and the PC detects something plugged but doesn’t recognize it.

Almost 100% sure I inverted the polarity on the VIN and GND ports while the MicroMaestro was connected by USB. I think i have used a 5V power source that has the color code on the cables all wrong.


Inverting VIN and GND should not damage the Maestro (it has reverse protection), but connecting forward or inverted power to any other pins could have done it. Still, the fact that the yellow LED blinks is a good sign. Can you describe the blinking more? Is it an even on-off blinking or a short on time followed by a long off time? Or is it a double-blink?

Can you verify that you have nothing else connected to your Maestro?

What happens if you plug in your power supply to Vin and GND (correctly, this time) while leaving it disconnected from USB?


Everything removed from the MicroMaestro, the yellow led blinks once and then stops when the USB is connected.

If the usb is left “halfway”, plugged just to the point before it “clicks” the yellow led blink once per second, and sometimes I get the green led to lit continuously, but there’ no connection with the PC. I’m beggining to think there’s a problem with the USB connector on the MM.

Oh! I forgot. If I power it using VIN/GND the yellow led blinks once per second. Nothing more.

Okay, this looks like it could be a damaged connector or chip on your Maestro. I still think you should try it with another USB cable if possible, since I have seen situations where a bad cable would only show problems with some devices. However, I will give you instructions for trying to get into the hardware bootloader, just in case that works. Here is an image showing the bootloader reset contacts on the Maestro:

With the Maestro unplugged, use a small screwdriver or a small piece of wire to short these two contacts together, being careful not to touch anything else on the board, then plug the Maestro into USB. I find that the easiest way to do this is to have a friend plug in the computer side of the cable while I hold the screwdriver in place. If it works, the device will connect to the computer and the green LED will begin to double-blink. You can then follow the firmware upgrade instructions to reload the firmware onto your Maestro.

I doubt that this will work, but it is worth a try! Please let me know what happens.



I know that this is an old topic but I had the same problem.
I found that somewhere soldering was bad so I heated up Maestro with strong hairdryer. It solved the problem, but I wasn’t sure this is a permanent solution because it can lose contact again, so I ordered a new Maestro.