Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Micro Maestro Control Center

Hello, I have recently bought a Micro Maestro 6 channel motor/servo controller board but am having issues with getting the control center to load. I have followed what instructions there are and have had no luck. I am using Linux/Debian on a raspberry pi and I know it’s possible to use these things to control a servo using a micro maestro because I’ve seen project pages on the web with similar set ups to my own. I’ve looked through the user guide and cannot find any information on why the control center will not load.

I have tried moving the Maestro Control Center around to different folders and that does not make a difference. I’ve tried cd’ing into the directory where the control center file is and then running the “./MaestroControlCenter” line of code whilst in the directory using terminal and it tries to open the center but it keeps saying something about a sigsegv error and that either something is wrong with a part of Mono or that one of the dll’s associated with the program I am running is corrupt. Can you please point me in the right direction on how to get this problem solved, just tell me what information you need and I will gladly post it up. I spent the last four to five hours messing around and updating/upgrading my RPi along with making sure that Mono was installed correctly etc. etc. and to be honest I am -very- frustrated. It really should not be this hard to load up the control center right?

Thanks for any help in advance,
Tom

Hello, Tom. I am sorry you are having trouble. We do not support running the Maestro Control Center on ARM-based CPUs like the one in the Raspberry Pi and have not tested it. I think some of our other customers have gotten it to work, though. Did you install libusb-1.0? Instead of paraphrasing error messages that the computer is giving you, could you please post them verbatim? Without the actual error message there is little hope that someone will be able to debug this for you. In fact, you should post all the output you are getting from mono.

Also, maybe you do not need to run the Maestro Control Center on the Raspberry Pi. What are you ultimately trying to accomplish?

–David

Did you ever manage to get the Maestro Control Center working? --David

Hi. I’m trying to connect my RPI to micro maestro 6 channel. I’ve tested it on windows 7 with MaestroControl Center and everything is ok, servos respond and move on… but in RPI:
MaestroControl Center: Not run… may errors received… I Think same about terminal etc etc but I can comunicate adapter using UscCmd… and everythig seems to go well but servos doesn’t move…
Did you succeed moving servos anyway ??

Thanks

It seems I am experiencing this problem with my new Raspberry Pi, Micro Maestro and the MaestroControlCenter. A status check with UscCmd shows the Maestro connected to the Pi, but initializing the control center aborts. Attached is the error log.

I thought it would be important to make the control center work in order to establish servo limits and ensure operation before doing any coding for a special application.

THANKS!
MicroControlCenter Error.txt (5.88 KB)

Unfortunately, we still do not support running the Maestro Control Center on ARM-based computers like the Raspberry Pi. The error you are getting is coming from deep within the GUI library we are using, and will probably be hard to fix.

–David