Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

MAX14870 Single Brushed DC Motor Driver Carrier only delivers 800mA?

I am trying to run a 12v motor (https://www.robotshop.com/uk/ghm-01-spur-gear-head-motor.html) with a stall current of 1.4A from a 5A lab power supply at 12v via a https://www.pololu.com/product/2961 (which uses the MAX14870 chip).

The motor just buzzes and a fault is indicated. I’m confident of the entire setup because it works for a much lighter motor. It also works if I limit the current from the supply to about 800mA.

It appears to me that these boards/chips can really only cope with a fraction of what it says on the datasheet, apparently around 800mA.

Hello.

The 1.7 A continuous current rating we specify on the product page is based our actual characterizations of the performance of the board, and the over-current threshold of the driver should be at least 6 A (as specified by the datasheet), so I suspect something about your setup is not behaving the way you think it is. The most likely explanation would be that your motor actually has a stall current well above 1.4 A (which seems very low for a motor of that size). Can you try powering your motor directly from your power supply and measure the stall current at a much lower voltage (e.g. 1 V)?

- Patrick

Hi Patrick

Thanks for the quick reply.

I did the test with the same 5A supply I used before with the current limit set to max (i.e. deliver 5A). I’m assuming to measure the stall current you literally stall the motor; if that is the case then:
1v: 80mA
4v: 410mA
8v: 780mA
12v: 1.4A

This is consistent with the (somewhat limited) data I have for the motor. Actually I measured at 1v intervals, but its roughly linear so I didn’t list them all.

I shouldn’t get anywhere near the 6A you mention. My supply is rated at 5A but I had it limited to 2A or less for the test.

Can you post some pictures of your setup and tell me how you are testing the driver? Also, how are you measuring the nFAULT pin?

- Patrick

Hi Patrick

I’m going to stop investigating this now; I have found an alternate motor driver which seems to work nicely.

Thanks for your assistance though.

Regards

Phil