Maestro with 12 and 18 channels does not accept serial commands anymore

I am controlling two maestro via serial communication (over USB, but not both at the same time) using the serial library of python and the maestro library here. That worked well in the past. Then I upgraded the 1.02 firmware to 1.03 and now the controller does not respond when sending commands. I reflashed them several times, no change. The strange thing is, when using the maestro control center everything works well. I have a serial sniffer to show the traffic and I can clearly see the traffic on the COM port as expected when using the python library or using the Pololu Serial Transmitter software, but I never get a respond from the controller. When using maestro control center I cannot see any traffic on the serial port, but the controller (and it’s attached servos) are reacting as expected. Does the maestro control center using another USB protocol than the serial one? The controller is correctly listed as two COM ports under Windows (I use the lower one described as command port) as well under MAC OS or Linux. I also tried to communicate with the Pololu Serial Transmitter but the controller does not respond.

Whats wrong? I cannot imagine that the upgrade was the problem, and I checked several time about the correct firmware. I tried all serial settings in the maestro control center. Any help is highly appreciated… thanks! And yes, I already read similar threads in this forum, they did not help… my code worked once like a charm…

Wit best regards


Hello, Bruno.

The Maestro Control Center uses the native USB interface, so it makes sense that you would not detect serial commands from it on the COM port with your sniffer.

You might try double checking that you are connecting to the correct COM port; it is unlikely the COM port numbers would change from the firmware upgrade, but it’s worth a quick check to make sure you are using the command port.

Updating the firmware would reset all of the Maestro settings, so you will need to reconfigure them to get it back to how it was. For example, by default the Maestro’s serial mode is “UART, detect baud rate” so it will not respond to serial commands sent to it’s virtual COM port. It will need to be changed to “USB Dual Port” or “USB Chained”. Other settings, such as the device number might also need to be changed.

If you continue having problems, can you post your Maestro settings file as well as the bytes you tried sending with the Serial Transmitter utility? You can save your Maestro settings file by selecting the “Save settings file…” option within the “File” drop-down menu of the Maestro Control Center.


Thanks Brandon!
I checked the COM ports several times (also on MAC and Ubuntu). Here the settings file and a screen shot of the transitter.

maestro_settings.txt (2.5 KB)
As you can see, there is no response from the controller when sending a “get position”. Device number is 12

Thank you for the screenshot and settings file. That is a strange problem; we tried to reproduce it here (using a 12- and 18-channel Mini Maestro freshly loaded with the 1.03 firmware and using your settings file and sending the same commands via the Serial Transmitter utility), but it worked fine for us. It also responded correctly with a test on Linux.

Could you try restarting your computer, in case the USB-to-serial driver is in a bad state somehow? What version of Windows are you using? Could you post a screenshot of your Device Manger (with the Maestro port entries expanded)? Could you try connecting your Maestro’s TX line to its RX line and running the same test with the Serial Transmitter utility to see if you get anything back?


Thank you Brandon
I think I have narrowed down the problem. I used an external USB hub. With the hub it did not work, when connected directly to the PC it worked. This is very strange since serial over USB is a very common protocol. The sad thing is, that nowadays notebooks (specially from Cupertino) only have one USB Port, so you rely on having an external USB hub. I use an ICY BOX now which works as a hub.
Thanks for your help!
Best regards


We have heard of other people having issues using particular USB hubs with the Maestro before, though I am not sure we have seen native USB work and not serial. You might try another model of USB hub.