Maestro & OceanServer Compass crashing WIN7 64bit

I am having trouble running both the Maestro 6 and the OceanServer OS5000 USB 3 axis digital compass with Win7 64bit. If I run the Maestro separately all is fine. If I run the OS5000 separately all is fine. If both are connected Win7 may lockup on boot. If I add the OS5000 to the USB bus after Win7 and the Maestro are up and running Win7 may lockup.

There was a reported issue with the OS5000 sending data on the USB bus too early so I issued the maximum delay.

Lockup doesn’t happen everytime. I can boot successfully 9 times in a row with both devices connected, convince myself that all is fine and then it will lockup on 10th boot.

I’ve tried several different hubs and installed all the latest drivers.

I’d hate to sucker my client with this, any ideas?

Hello, johnm.

I’m sorry you are having a problem with your setup, and I’m sorry that it’s such an unpredictable problem.

It might be possible to solve the problem by making sure that the devices are plugged in to different USB host controllers. With the Maestro and the OS5000 plugged in, please go to your computer’s Device Manager, select “View -> Devices by Connection”, and try to find the Maestro and the OS5000. They should be at a location like “ACPI x64-based PC -> Microsoft ACPI-Compliant System -> PCI bus -> Standard OpenHCD USB Host Controller -> USB Root Hub”. See if both of the devices are listed under the same USB Host Controller. If they are, try changing the ports they are plugged in to, to make them be on different host controllers. If you aren’t sure how to interpret the items in your Device Manager, post a screenshot here.

I’d like to look in to this issue a bit more. Could you post a link to the product page of the OS5000? Could you also post a link to the information you found about the OS5000’s USB issue?



I see where you’re going.

The task was to connect a Maestro 6, National Instruments 6009, and a OS5000US to a Targus 4 port mini hub connected to a quality 15’ USB cable to an Acer Aspire notebook running Win 7 64 bit and LabVIEW 2009 64 bit. Keywords are 1 wire and small.

I bench tested this configuration with a powered D-Link USB hub and had the same issues.

I had to ship everything last week with the compass disconnected. I am fishing for ideas no how to proceed when it comes back.

The Device is a Ocean Server OS5000-US Solid State Tilt Compensated 3 Axis Digital Compass (USB & Serial)

Doucmentation … Manual.pdf

Company Website

USB interface used on the OS5000US is the SILABS CP2102. I installed the latest drivers from Pololu, NI and SILABS.

Booting WIN7, the Maestro and the OS5000US appeared to have issues when connected to the same hub.

Any ideas are appreiceated.



Are you still having this problem?

I recently found a mistake in the original Micro Maestro 6-channel controller’s firmware that has a chance of causing problems like the one you are experiencing. I have made a new experimental version of the Micro Maestro firmware and attached the firmware upload file to this message. You could try the new firmware and see if the problem goes away. Note that this experimental firmware version has not been thoroughly tested, so you should be on the lookout for new bugs that it might have.

To change your firmware: Unzip the attached zip archive to get the pgm file inside, then follow the firmware upgrade instructions from the Maestro User’s guide. After updating your Maestro’s firmware, you should see “Firmware version: 9.99” in the control center.

You can switch back to the old firmware at any time by following the instructions in the user’s guide.

Please let us know what your results are!

–David Grayson (18.1 KB)


On a Win XP sp3 x32 machine I was able to boot 10 for 10 tries with the
Maeseto and OS5000 compass connected to the same USB hub. Win XP appears to
be a whole lot more forgiving.

On 3 of the 10 boots the compass port would not open.

I downloaded your v9.99 firmware and carefully followed the firmware update
documentation. I did see the double heart beat per 4.f.6. I verified the
proper com port in the Device Manager and set the COM port to 15. I pointed
the updater to your file v9.99.pgm. I thought all was going well and hit
Program (4.f.9). I received the message, " There was a timeout while trying
to talk to the bootloader. The write timed out."

Backed into a corner with no apparent place to go and thinking no harm was
done, I rebooted the computer.

The Maestro6 appears to be dead, no leds, now what?

Hello, johnm. I just replied to the email you sent me which appears to be the same as your last forum post. For anyone else who is following the discussion, here is my response to the email and the forum post:

I’m sorry that the firmware upgrade process is giving you trouble. I don’t know why the write timed out, but I’m hopeful that the firmware upgrade will work if you try it a second time.

We designed the Maestro so that you can get it in to bootloader mode even if the firmware was corrupted. To get it back in to bootloader mode, you can follow these steps:

  1. Make sure the Maestro is powered off. It’s best if you can just disconnect everything from it.
  2. Using a screwdriver, a small piece of wire, or some other conductive tool, short the exposed bootloader pad to the +5V hole next to it. The pads are shown in this picture:
  3. While the pads are shorted together, connect the Maestro to USB. Usually the easiest way to do this is to have one end of the USB cable already plugged in to the Maestro, and connect the other end to the computer after you have shorted the pads.

This might take a few tries if you have trouble shorting together the pads. But once it works, you should see the same double-blinking green LED pattern you saw before, and the Maestro’s bootloader should once again be visible in your device manager. Then you can stop shorting together the pads, and retry the firmware upgrade procedure, starting at step 6:

This should allow you to load the experimental (or standard) firmware on the Maestro.

Let me know how this works for you!



Firmware update went well, thank-you, I thought I trashed the Maestro.

I just did 12 cold starts from Win XP Sp3 x32 with a NI-6009, Maestro6 and the OS5000 compass connected to a D-link 7 port hub. The compass failed to start 5 times. The Maestro and NI-6009 started every time. Win XP appears to be more forgiving than Win7 as it didn’t lock up even once in 22 boots. I may not see the Win7 computer for a few weeks.

Anything else up your sleeve?

I’m going to be out of the office until Monday and scratching my head all weekend.

Thanks for your help,



This morning I tried removing the Maestro 6 from the USB bus. I left the NI-6009 and the OS5000 compass attached. I cold started 10 times without a problem. I then attached another NI-6009 and a webcam to the bus. I cold started 5 times without a problem.

Right now, my fall back position is to abandon Win 7 x64 and run my test platform with Win XP x32. I can deal with the compass not starting 40% of the time and XP doesn’t crash on boot.

The real test is running the Maestro 6 and the OS5000 compass with Win7. I’ll run some more tests when I get the Win7 computer back.

I’m open for any suggestions you might have.



Sorry johnm, I’m out of ideas. But if I come up with anything I’ll let you know. --David