Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Maestro mini 12 with LAC

I currently have a 3 button set position set up with the Maestro mini 12 that worked perfect with my linear servo. I needed more torque, so I went with a PA-14p actuator with a LAC. I’ve wired everything in but my script will not move the actuator. I can however control the actuator in the Pololu Maestro control center under the status tab. I’ve tried to change the values for the actuator and still no luck.
Here is a copy of my script. Seems to be pretty basic, but any input would help.
Thanks for your help and time in advance.
Rob

begin
  button_a if sequence_a endif
  button_b if sequence_b endif
  button_c if sequence_c endif
repeat

sub button_a
  1 get_position 50 less_than
  return
 
sub button_b
  2 get_position 50 less_than
  return
 
sub button_c
  3 get_position 50 less_than
  return
 
sub sequence_a
  1715 0 servo 100 delay
  return
   
sub sequence_b
  1850 0 servo 100 delay
  return
 
sub sequence_c
  2015 0 servo 100 delay
  return

Hello, Rob.

I moved your post to the “Servo controllers and servos” section of the forum since it seems mostly related to the Maestro.

It looks like you are probably using the wrong units for the servo position in your script. The units in the Maestro script should be in quarter-microseconds, while the “Status” tab shows the units in microseconds (µs).

For example, if you want the pulse width on channel 0 to be 1715 µs, your script should use 6860 0 servo. If you want the pulse width to be easily readable from your script, and do not need sub-microsecond resolution, you could just add 4 times after the position value (e.g. 1715 0 servo would become 1715 4 times 0 servo).

Brandon

I changed the servo position to 1715 times 4 0 servo along with the correct units for the other 2 buttons. Every time I hit 2 of the buttons the Maestro is disconnecting from the computer. the maestro is still responding to the status bar movement, just not the script.

Did you change your code to 1715 times 4 0 servo or 1715 4 times 0 servo like I suggested? The 1715 times 4 0 servo way will not work since it will essentially multiple 1715 by 0, then try to set the servo to a position of 16 microseconds. The values you want multiplied together need to be on the stack before calling the TIMES command.

Can you clarify what you mean when you say it is disconnecting from the computer? What are you doing to get it to respond to the sliders in the “Status” tab (e.g. are you having to disconnect and reconnect it from USB every time you try to run the script)?

If it is disconnecting from USB, that could be an indication it is browning out in some way, and if it is only when you press one of the buttons, you might have them connected incorrectly. Could you post pictures of your setup that show all of your connections? Also, could you post your Maestro settings file? You can save your settings file by selecting the “Save settings file…” option within the “File” drop-down menu of the Maestro Control Center while the Maestro is connected.

Brandon