Maestro Control Center missing bottom buttons?

The bottom of the of Maestro Control Center screen is not visible. The documentation shows that the each tab has two buttons at the bottom: “Save Frame”, “Apply Settings”. I cannot get a window to display them on any tab.

The very top edge of the “Save Frame” button can be seen on the “Errors” tab. That window is resizable, and that top edge stays visible when resized, but never comes into it.

I am using a DELL laptop running XP. I have the 12-Channel item #1352.

That’s weird. I wonder if you customized your font or windows style in some way that we weren’t prepared for.

Could you post some screenshots of the Maestro Control Center to illustrate what you’re talking about? Use the “Upload Attachment” tab at the bottom of the screen.

In the mean time, please try using Alt+A to Apply Settings and Alt+S to save a frame.


Thank you for telling me the hot-key functions.

I am attempting to use the Maestro with the Christmas sequencing program Vixen. It has a MiniSCC plugin that I am hoping will work with the Maestro. Looks like it uses the usb serial port emulation for communication. In any case the default Maestro configuration does not respond to Vixen signals.

I just tested Vixen and it is working with the Maestro controller.

I used the MiniSCC plugin in Vixen, and Maestro is configured to use the USB Dual Port serial mode.

I’ve had the same problem with my netbook. My larger monitor has no problem. The Alt A solution is good to know.

Thanks for bringing this to my attention. I intend to look in to it soon and hopefully make a fixed version of the Maestro Control Center. --David

Rocuro and RussF,

I tried to reproduce the problem you were having where the Maestro Control Center buttons at the bottom are not visible. I used a Windows XP system and tried changing the DPI and various text sizes, but no matter what I did the buttons were always completely visible.

Do either of you remember what you might have changed about your display settings?

I would appreciate it if you could you tell me what DPI your monitor is set to. To find your DPI: Right click on the background. Select Properties. In the Settings tab, click the Advanced button. In the General tab of the new dialog, find your DPI setting.

I would also appreciate it if you tried reseting your display settings back their defaults and see if that solves the problem. Right click on the background. Select Properties. In the Themes tab, save your current theme so you don’t lose it. Then select the “Windows XP” theme and click Apply. After you have done this, please check to see if your Maestro Control Center buttons are visible as they should be.


Having the same problem

I had my windows display setting to “Medium” 125% increase font size.

I don’t want to go blind, perhaps you will consider fixing this in another version! I have to reboot and loose the larger font size just to see it.

Also instead of control + A, i click the last visible box, and two or three tabs followed by hitting space does the trick (lame) but thanks for your efforts.

a cool controller : )


I am sorry you are having the same problem. As I said before, Alt+A should work for applying the settings to the device (but not Ctrl+A).

What operating system are you using? Also, could you please click Help -> About and tell me what version of the Maestro Control Center you have?

Sorry for the delaying in answering.