Maestro 6 - MaestroControlCenter works, but nothing else

Hi everyone,

I am running ubuntu 14.04 and have gotten my maestro 6 channel controller to work just fine with the Maestro Center. I can not however get any other example to work.

I have tried the cross platform C example, the bash script example and I can not get anything EXCEPT Maestro control center to do anything.

If I do not start the maestro control center, my yellow light continues to flash about once a second. When I try to run any of the examples, I can see the green like “blip” for a fraction of a second, but nothing moves at all.

If i start the Maestro control center, I “check” the enabled box for channel 0, then my yellow light starts to “double flash”, I also see a ton more activity on the green light as Maestro center starts up.

Are there some other commands that need to be issued to “enable” servo ports … or do some thing? I feel like I am missing some thing fundamental here, like the docs and examples arent including the information required for “initialization” or something.

I have tried this again, on a different laptop with the same results.

I took the C example from

I saved the file as test.c and did

gcc -o test test.c

and then

sudo ./test

The program just hangs, and the servo attached to the pololu does nothing. The pololu still only blinks the yellow light once a second - no double blink indicating that the servo is “active”.

What am i doing wrong here - please help.

hum … i changed the mode to usb chained in the maestro control center … and then things started working for a bit, then stopped.

I then unplugged/replugged usb to reboot the maestro and things appear to be working at this point… strange.

i may be an idiot …lol. I think i had it set in UART mode this whole time. I will verify with my other laptop when I get home.


I am glad that you found out what the problem was; thank you for letting us know.